aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-09-07 10:06:15 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-13 22:53:41 +0100
commit99ed71faec745ced91a00d46c6512b27c9892d2b (patch)
tree415f6e86b8ccd48416f041673481ad4914b3a4fe /tools
parenta1527207b8f23d4084a18e988605fd30c5e72ca8 (diff)
downloadupstream-99ed71faec745ced91a00d46c6512b27c9892d2b.tar.gz
upstream-99ed71faec745ced91a00d46c6512b27c9892d2b.tar.bz2
upstream-99ed71faec745ced91a00d46c6512b27c9892d2b.zip
tools/autoconf: clean up build recipes
The configure option datarootdir defaults to PREFIX/share. The Host/Clean define should be Host/Uninstall otherwise it is removing the build directory before there is a chance to try "make uninstall" in that directory. Host/Clean/Default is no longer defined. Use default build recipes defined in host-build.mk instead of custom ones that are equivalent. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools')
-rw-r--r--tools/autoconf/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index 6eb64d77d5..b9c2f93ff3 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -15,23 +15,15 @@ PKG_HASH:=64ebcec9f8ac5b2487125a86a7760d2591ac9e1d3dbd59489633f9de62a57684
include $(INCLUDE_DIR)/host-build.mk
-HOST_CONFIGURE_ARGS += \
- --datarootdir=$(STAGING_DIR_HOST)/share
-
HOST_CONFIGURE_VARS += \
PERL="/usr/bin/env perl"
define Host/Compile
- export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
- export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
+ $(call Host/Compile/Default)
endef
-define Host/Clean
- -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
endef
$(eval $(call HostBuild))