aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorLinhui Liu <liulinhui36@gmail.com>2023-03-31 21:34:01 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-01 21:58:31 +0200
commit3efd49a588d7d7c800b03551552d120b8af44bb7 (patch)
tree3b1341939b84fc5e1cbc92ea61b25c760074bedc /tools
parent37dbe302158c7c567835ed64c118236dfc0425b2 (diff)
downloadupstream-3efd49a588d7d7c800b03551552d120b8af44bb7.tar.gz
upstream-3efd49a588d7d7c800b03551552d120b8af44bb7.tar.bz2
upstream-3efd49a588d7d7c800b03551552d120b8af44bb7.zip
tools/squashfs4: enable parallel builds
Run `time make tools/squashfs4/{clean,compile} -j$(nproc)` Before: real 0m8.803s user 0m12.415s sys 0m1.317s After: real 0m13.781s user 0m13.290s sys 0m1.528s Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/squashfs4/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
index 7c8bcf1a72..bcbe98e0dd 100644
--- a/tools/squashfs4/Makefile
+++ b/tools/squashfs4/Makefile
@@ -17,11 +17,13 @@ PKG_SOURCE_DATE:=2022-03-17
PKG_SOURCE_VERSION:=afdd63fc386919b4aa40d573b0a6069414d14317
PKG_MIRROR_HASH:=59c294e00ddfc1f4bda658c7567584ce35fdd479c413ebdb1376981b27737be1
+HOST_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
+$(HOST_MAKE_VARS) \
- $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/squashfs-tools \
XZ_SUPPORT=1 \
LZMA_XZ_SUPPORT=1 \
EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \