aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-02-05 21:14:19 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-08 00:12:23 +0100
commit38350650cbc43c0386977c9ca532b71ece15c80b (patch)
treed4d396e1da1518414fe6d2943f08a9cff33b8a7f /tools
parent628870146df4cc327852b1c5cf351d5bde26b61f (diff)
downloadupstream-38350650cbc43c0386977c9ca532b71ece15c80b.tar.gz
upstream-38350650cbc43c0386977c9ca532b71ece15c80b.tar.bz2
upstream-38350650cbc43c0386977c9ca532b71ece15c80b.zip
tools/e2fsprogs: update to 1.46.6
Release information: https://e2fsprogs.sourceforge.net/e2fsprogs-release.html#1.46.6 Remove upstreamed patch: - 004-CVE-2022-1304-libext2fs-add-sanity-check-to-extent-manipulation.patch Refresh patch: - 003-no-crond.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools')
-rw-r--r--tools/e2fsprogs/Makefile6
-rw-r--r--tools/e2fsprogs/patches/003-no-crond.patch8
-rw-r--r--tools/e2fsprogs/patches/004-CVE-2022-1304-libext2fs-add-sanity-check-to-extent-manipulation.patch50
3 files changed, 7 insertions, 57 deletions
diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index a8bd745afb..1c72611df7 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
PKG_CPE_ID:=cpe:/a:e2fsprogs_project:e2fsprogs
-PKG_VERSION:=1.46.5
-PKG_HASH:=2f16c9176704cf645dc69d5b15ff704ae722d665df38b2ed3cfc249757d8d81e
-PKG_RELEASE:=2
+PKG_VERSION:=1.46.6
+PKG_HASH:=a77517f19ff5e4e97ede63536566865dd5d48654e13fc145f5f2249ef7c4f4fc
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/tytso/e2fsprogs/v$(PKG_VERSION)/
diff --git a/tools/e2fsprogs/patches/003-no-crond.patch b/tools/e2fsprogs/patches/003-no-crond.patch
index a7ea52b1ac..67ddd4ab0c 100644
--- a/tools/e2fsprogs/patches/003-no-crond.patch
+++ b/tools/e2fsprogs/patches/003-no-crond.patch
@@ -1,11 +1,11 @@
--- a/configure
+++ b/configure
-@@ -12538,7 +12538,7 @@ $as_echo_n "checking for system crontab
+@@ -15259,7 +15259,7 @@ then :
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: ${crond_dir}" >&5
- $as_echo "${crond_dir}" >&6; }
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: ${crond_dir}" >&5
+ printf "%s\n" "${crond_dir}" >&6; }
- have_crond="yes"
+ have_crond="no"; with_crond_dir=""
- else
+ else $as_nop
diff --git a/tools/e2fsprogs/patches/004-CVE-2022-1304-libext2fs-add-sanity-check-to-extent-manipulation.patch b/tools/e2fsprogs/patches/004-CVE-2022-1304-libext2fs-add-sanity-check-to-extent-manipulation.patch
deleted file mode 100644
index e5a76161f2..0000000000
--- a/tools/e2fsprogs/patches/004-CVE-2022-1304-libext2fs-add-sanity-check-to-extent-manipulation.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From ab51d587bb9b229b1fade1afd02e1574c1ba5c76 Mon Sep 17 00:00:00 2001
-From: Lukas Czerner <lczerner@redhat.com>
-Date: Thu, 21 Apr 2022 19:31:48 +0200
-Subject: libext2fs: add sanity check to extent manipulation
-
-It is possible to have a corrupted extent tree in such a way that a leaf
-node contains zero extents in it. Currently if that happens and we try
-to traverse the tree we can end up accessing wrong data, or possibly
-even uninitialized memory. Make sure we don't do that.
-
-Additionally make sure that we have a sane number of bytes passed to
-memmove() in ext2fs_extent_delete().
-
-Note that e2fsck is currently unable to spot and fix such corruption in
-pass1.
-
-Signed-off-by: Lukas Czerner <lczerner@redhat.com>
-Reported-by: Nils Bars <nils_bars@t-online.de>
-Addresses: https://bugzilla.redhat.com/show_bug.cgi?id=2068113
-Addresses: CVE-2022-1304
-Addresses-Debian-Bug: #1010263
-Signed-off-by: Theodore Ts'o <tytso@mit.edu>
----
- lib/ext2fs/extent.c | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
---- a/lib/ext2fs/extent.c
-+++ b/lib/ext2fs/extent.c
-@@ -495,6 +495,10 @@ retry:
- ext2fs_le16_to_cpu(eh->eh_entries);
- newpath->max_entries = ext2fs_le16_to_cpu(eh->eh_max);
-
-+ /* Make sure there is at least one extent present */
-+ if (newpath->left <= 0)
-+ return EXT2_ET_EXTENT_NO_DOWN;
-+
- if (path->left > 0) {
- ix++;
- newpath->end_blk = ext2fs_le32_to_cpu(ix->ei_block);
-@@ -1630,6 +1634,10 @@ errcode_t ext2fs_extent_delete(ext2_exte
-
- cp = path->curr;
-
-+ /* Sanity check before memmove() */
-+ if (path->left < 0)
-+ return EXT2_ET_EXTENT_LEAF_BAD;
-+
- if (path->left) {
- memmove(cp, cp + sizeof(struct ext3_extent_idx),
- path->left * sizeof(struct ext3_extent_idx));