aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-02-06 23:07:24 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-02-18 21:11:36 +0100
commit01262c921c7cbafc9a32b912e42c58982f47725c (patch)
tree8c5fee2472391ffc9fd67ccf5f2e8960161a1b8c /tools
parent78dc8e2b13df439db92f233fe61d75959ffb57a6 (diff)
downloadupstream-01262c921c7cbafc9a32b912e42c58982f47725c.tar.gz
upstream-01262c921c7cbafc9a32b912e42c58982f47725c.tar.bz2
upstream-01262c921c7cbafc9a32b912e42c58982f47725c.zip
tools/squashfs: rename to squashfs3-lzma
The name of squashfs is confusing since in reality it's a really old version using an old lzma library. This tools is used for old ath79 netgear target and to produde a fake squasfs3 image needed for some specific bootloader from some OEM (AVM for example) Rename squashfs tool to squasfs3-lzma to better describe it. Rename the installed bin from mksquashfs-lzma to mksquashfs3-lzma. Use tar transform to migrate the root directory in tar to the new naming. Drop redundant PKG_CAT variable not needed anymore. Also update any user of this tool. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile4
-rw-r--r--tools/squashfs3-lzma/Makefile (renamed from tools/squashfs/Makefile)21
-rw-r--r--tools/squashfs3-lzma/patches/100-lzma.patch (renamed from tools/squashfs/patches/100-lzma.patch)0
-rw-r--r--tools/squashfs3-lzma/patches/110-no_nonstatic_inline.patch (renamed from tools/squashfs/patches/110-no_nonstatic_inline.patch)0
-rw-r--r--tools/squashfs3-lzma/patches/120-add-fixed-timestamp-support.patch (renamed from tools/squashfs/patches/120-add-fixed-timestamp-support.patch)0
-rw-r--r--tools/squashfs3-lzma/patches/130-include_sysmacros.patch (renamed from tools/squashfs/patches/130-include_sysmacros.patch)0
-rw-r--r--tools/squashfs3-lzma/patches/140-gcc-10-fix.patch (renamed from tools/squashfs/patches/140-gcc-10-fix.patch)0
7 files changed, 15 insertions, 10 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 7b3a8eb142..aa80ee4ba6 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -71,7 +71,7 @@ tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_LZ4_TOOLS),y) += lz4
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_LZO_TOOLS),y) += lzop
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_TOOLCHAIN),y) += gmp mpc mpfr
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(CONFIG_TARGET_apm821xx)$(CONFIG_TARGET_gemini),y) += genext2fs
-tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(CONFIG_TARGET_ath79),y) += lzma-old squashfs
+tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(CONFIG_TARGET_ath79),y) += lzma-old squashfs3-lzma
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(CONFIG_TARGET_mxs),y) += elftosb sdimage
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(CONFIG_TARGET_realtek),y) += 7z
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(CONFIG_TARGET_tegra),y) += cbootimage cbootimage-configs
@@ -116,7 +116,7 @@ $(curdir)/patchelf/compile := $(curdir)/libtool/compile
$(curdir)/pkgconf/compile := $(curdir)/meson/compile
$(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compile
$(curdir)/sdcc/compile := $(curdir)/bison/compile
-$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
+$(curdir)/squashfs3-lzma/compile := $(curdir)/lzma-old/compile
$(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
$(curdir)/zstd/compile := $(curdir)/meson/compile
diff --git a/tools/squashfs/Makefile b/tools/squashfs3-lzma/Makefile
index 385cf69d9d..b02018629e 100644
--- a/tools/squashfs/Makefile
+++ b/tools/squashfs3-lzma/Makefile
@@ -6,16 +6,21 @@
#
include $(TOPDIR)/rules.mk
-PKG_NAME:=squashfs
+PKG_NAME:=squashfs3-lzma
PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
PKG_VERSION:=3.0
-PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tar.gz
+PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/squashfs
PKG_HASH:=39dbda43cf118536deb746c7730b468702d514a19f4cfab73b710e32908ddf20
-PKG_CAT:=zcat
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)$(PKG_VERSION)
+# Tar directory is squashfs3.0 that conflict with any pattern
+# currently using for host tools. (PKG_NAME-PKG_VERSION)
+# Also this got renamed to a more correct name
+# from squashfs to squashfs3-lzma.
+# Use tar transform to rename the root directory to this new
+# name.
+TAR_OPTIONS+=--transform=s/^squashfs/$(PKG_NAME)-/
include $(INCLUDE_DIR)/host-build.mk
@@ -29,13 +34,13 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs-lzma $(STAGING_DIR_HOST)/bin/
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs-lzma $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs-lzma $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs-lzma $(STAGING_DIR_HOST)/bin/unsquashfs3-lzma
endef
define Host/Clean
- rm -f $(STAGING_DIR_HOST)/bin/mksquashfs-lzma
- rm -f $(STAGING_DIR_HOST)/bin/unsquashfs-lzma
+ rm -f $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma
+ rm -f $(STAGING_DIR_HOST)/bin/unsquashfs3-lzma
endef
$(eval $(call HostBuild))
diff --git a/tools/squashfs/patches/100-lzma.patch b/tools/squashfs3-lzma/patches/100-lzma.patch
index 73f6a4e055..73f6a4e055 100644
--- a/tools/squashfs/patches/100-lzma.patch
+++ b/tools/squashfs3-lzma/patches/100-lzma.patch
diff --git a/tools/squashfs/patches/110-no_nonstatic_inline.patch b/tools/squashfs3-lzma/patches/110-no_nonstatic_inline.patch
index 8e288f336e..8e288f336e 100644
--- a/tools/squashfs/patches/110-no_nonstatic_inline.patch
+++ b/tools/squashfs3-lzma/patches/110-no_nonstatic_inline.patch
diff --git a/tools/squashfs/patches/120-add-fixed-timestamp-support.patch b/tools/squashfs3-lzma/patches/120-add-fixed-timestamp-support.patch
index e2f4bb2e04..e2f4bb2e04 100644
--- a/tools/squashfs/patches/120-add-fixed-timestamp-support.patch
+++ b/tools/squashfs3-lzma/patches/120-add-fixed-timestamp-support.patch
diff --git a/tools/squashfs/patches/130-include_sysmacros.patch b/tools/squashfs3-lzma/patches/130-include_sysmacros.patch
index f0149d6f65..f0149d6f65 100644
--- a/tools/squashfs/patches/130-include_sysmacros.patch
+++ b/tools/squashfs3-lzma/patches/130-include_sysmacros.patch
diff --git a/tools/squashfs/patches/140-gcc-10-fix.patch b/tools/squashfs3-lzma/patches/140-gcc-10-fix.patch
index a02641f307..a02641f307 100644
--- a/tools/squashfs/patches/140-gcc-10-fix.patch
+++ b/tools/squashfs3-lzma/patches/140-gcc-10-fix.patch