aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-08-30 08:41:07 +0200
committerPetr Štetiar <ynezz@true.cz>2022-09-16 18:50:46 +0200
commitb5e39355e4121bd6288e2fc4a434a785bd6d6285 (patch)
treec28eac945f10d765a28a677d895ae3643435e0dd /tools
parentb531611f57342cbfa8075a38f1ade51fe56c1e9f (diff)
downloadupstream-b5e39355e4121bd6288e2fc4a434a785bd6d6285.tar.gz
upstream-b5e39355e4121bd6288e2fc4a434a785bd6d6285.tar.bz2
upstream-b5e39355e4121bd6288e2fc4a434a785bd6d6285.zip
tools: remove xxd package
It shouldn't be needed anymore as we've now `scripts/xxdi.pl`, which should be self contained and fully compatible `xxd -i` replacement. Fixes: #10555 Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 88c9056a70901577489ecdc7a25207a9b7576d6e)
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/xxd/Makefile19
2 files changed, 1 insertions, 20 deletions
diff --git a/tools/Makefile b/tools/Makefile
index ec382b4122..c18c2b4242 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -25,7 +25,7 @@ tools-y += autoconf autoconf-archive automake bc bison cmake cpio dosfstools
tools-y += e2fsprogs fakeroot findutils firmware-utils flex gengetopt
tools-y += libressl libtool lzma m4 make-ext4fs meson missing-macros mkimage
tools-y += mklibs mtd-utils mtools ninja padjffs2 patch-image
-tools-y += patchelf pkgconf quilt squashfskit4 sstrip xxd zip zlib zstd
+tools-y += patchelf pkgconf quilt squashfskit4 sstrip zip zlib zstd
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_ISL) += isl
tools-$(BUILD_TOOLCHAIN) += expat gmp mpc mpfr
diff --git a/tools/xxd/Makefile b/tools/xxd/Makefile
deleted file mode 100644
index c3cc6863cc..0000000000
--- a/tools/xxd/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-or-later
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=xxd
-PKG_VERSION:=1.10
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://grail.cba.csuohio.edu/~somos/
-PKG_HASH:=9bf05c19b9084973e3cc877696a7f9881a5c87fa5a9fa438d9962519726559f9
-PKG_CPE_ID:=cpe:/a:vim:vim
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/xxd $(STAGING_DIR_HOST)/bin/
-endef
-
-$(eval $(call HostBuild))