aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-02-07 09:03:13 +0100
committerJo-Philipp Wich <jo@mein.io>2022-02-07 09:03:19 +0100
commitaf79853c73ad333b71a1ca5e3fbf58e168a953b6 (patch)
tree1dc7e0352be71b4a16c744103e618b98c19ee4b4 /tools
parent3343ca7e6837b2ac5f237ea78bf73d50831dea20 (diff)
downloadupstream-af79853c73ad333b71a1ca5e3fbf58e168a953b6.tar.gz
upstream-af79853c73ad333b71a1ca5e3fbf58e168a953b6.tar.bz2
upstream-af79853c73ad333b71a1ca5e3fbf58e168a953b6.zip
Revert "tools/zstd: update to 1.5.2"
This reverts commit 8de901ccf7e2b227bd970e9c477f00c15ce6aae9. Apparently this update breaks tools building. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/zstd/Makefile30
2 files changed, 11 insertions, 21 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 0950f3aee1..681344a014 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -74,7 +74,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/compile
$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
$(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
$(curdir)/zlib/compile := $(curdir)/cmake/compile
-$(curdir)/zstd/compile := $(curdir)/meson/compile
+$(curdir)/zstd/compile := $(curdir)/cmake/compile
ifneq ($(HOST_OS),Linux)
$(curdir)/squashfskit4/compile += $(curdir)/coreutils/compile
diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index 93f6745976..b93a5d2b52 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -1,35 +1,25 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zstd
-PKG_VERSION:=1.5.2
+PKG_VERSION:=1.5.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
-PKG_HASH:=7c42d56fac126929a6a85dbc73ff1db2411d04f104fae9bdea51305663a83fd0
+PKG_HASH:=5194fbfa781fcf45b98c5e849651aa7b3b0a008c6b72d4a0db760f3002291e94
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:facebook:zstandard
-include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/meson.mk
-
-MESON_HOST_BUILD_DIR:=$(HOST_BUILD_DIR)/build/meson/openwrt-build
+CMAKE_SOURCE_SUBDIR:=build/cmake
-HOSTCC:= $(HOSTCC_NOCACHE)
-HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOST)/lib
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
-MESON_HOST_ARGS += \
- -Dlegacy_level=7 \
- -Ddebug_level=0 \
- -Dbacktrace=false \
- -Dstatic_runtime=false \
- -Dbin_programs=true \
- -Dbin_tests=false \
- -Dbin_contrib=false \
- -Dmulti_thread=enabled \
- -Dzlib=disabled \
- -Dlzma=disabled \
- -Dlz4=disabled
+CMAKE_HOST_OPTIONS += \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_C_COMPILER_LAUNCHER="" \
+ -DCMAKE_C_COMPILER=$(HOSTCC_NOCACHE) \
+ -DZSTD_LEGACY_SUPPORT=OFF
$(eval $(call HostBuild))