aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-01-30 19:03:41 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-01 00:08:08 +0100
commit94dd68ff736c75d628a98a1f050d7f0454fc4af1 (patch)
tree50d88e6696eba35f13b2eb9725c06d6b769858db /tools
parent2d5f03205ab81fcbee6ef2d2853db98a85f0ecd3 (diff)
downloadupstream-94dd68ff736c75d628a98a1f050d7f0454fc4af1.tar.gz
upstream-94dd68ff736c75d628a98a1f050d7f0454fc4af1.tar.bz2
upstream-94dd68ff736c75d628a98a1f050d7f0454fc4af1.zip
tools/zstd: update to 1.5.2
Switched to building with meson as it's faster and does not need a dependency on cmake, which takes a long time to build. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/zstd/Makefile30
2 files changed, 21 insertions, 11 deletions
diff --git a/tools/Makefile b/tools/Makefile
index a13c2e82b5..4c2aa1a1e9 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -74,7 +74,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/compile
$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
$(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
$(curdir)/zlib/compile := $(curdir)/cmake/compile
-$(curdir)/zstd/compile := $(curdir)/cmake/compile
+$(curdir)/zstd/compile := $(curdir)/meson/compile
ifneq ($(HOST_OS),Linux)
$(curdir)/squashfskit4/compile += $(curdir)/coreutils/compile
diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index b93a5d2b52..93f6745976 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -1,25 +1,35 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zstd
-PKG_VERSION:=1.5.0
+PKG_VERSION:=1.5.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
-PKG_HASH:=5194fbfa781fcf45b98c5e849651aa7b3b0a008c6b72d4a0db760f3002291e94
+PKG_HASH:=7c42d56fac126929a6a85dbc73ff1db2411d04f104fae9bdea51305663a83fd0
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:facebook:zstandard
-CMAKE_SOURCE_SUBDIR:=build/cmake
-
include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/cmake.mk
+include $(INCLUDE_DIR)/meson.mk
+
+MESON_HOST_BUILD_DIR:=$(HOST_BUILD_DIR)/build/meson/openwrt-build
+
+HOSTCC:= $(HOSTCC_NOCACHE)
+HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOST)/lib
-CMAKE_HOST_OPTIONS += \
- -DBUILD_TESTING=OFF \
- -DCMAKE_C_COMPILER_LAUNCHER="" \
- -DCMAKE_C_COMPILER=$(HOSTCC_NOCACHE) \
- -DZSTD_LEGACY_SUPPORT=OFF
+MESON_HOST_ARGS += \
+ -Dlegacy_level=7 \
+ -Ddebug_level=0 \
+ -Dbacktrace=false \
+ -Dstatic_runtime=false \
+ -Dbin_programs=true \
+ -Dbin_tests=false \
+ -Dbin_contrib=false \
+ -Dmulti_thread=enabled \
+ -Dzlib=disabled \
+ -Dlzma=disabled \
+ -Dlz4=disabled
$(eval $(call HostBuild))