aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-01-16 01:30:29 +0100
committerDavid Bauer <mail@david-bauer.net>2023-01-16 23:58:16 +0100
commit807483d3365f3dd011e3790695512d443cf2f267 (patch)
treee02b2e346af6775767f49a82e5b40ee07ee91ea3 /tools
parent3bc6d2af76e29dea23ffd1a96cbbf9c36fc915a3 (diff)
downloadupstream-807483d3365f3dd011e3790695512d443cf2f267.tar.gz
upstream-807483d3365f3dd011e3790695512d443cf2f267.tar.bz2
upstream-807483d3365f3dd011e3790695512d443cf2f267.zip
dosfstools: switch to AC_CHECK_LIB
This fixes spurious build-errors on OpenWrt, where the AM_ICONV macro is undefined while invoking autoconfig. Later in the build, the ICONV LDOPTIONS are set to @LIBICONV@, failing the build. Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 9300a20dcce2217b121bd2020cc1a4ea41fa4475)
Diffstat (limited to 'tools')
-rw-r--r--tools/dosfstools/patches/101-config-switch-to-AC_CHECK_LIB.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/dosfstools/patches/101-config-switch-to-AC_CHECK_LIB.patch b/tools/dosfstools/patches/101-config-switch-to-AC_CHECK_LIB.patch
new file mode 100644
index 0000000000..ba2d00bf84
--- /dev/null
+++ b/tools/dosfstools/patches/101-config-switch-to-AC_CHECK_LIB.patch
@@ -0,0 +1,28 @@
+From e7671c2a3be03d790cbc225cd3e784b5434fb5da Mon Sep 17 00:00:00 2001
+From: David Bauer <mail@david-bauer.net>
+Date: Mon, 16 Jan 2023 01:29:22 +0100
+Subject: [PATCH] config: switch to AC_CHECK_LIB
+
+This fixes spurious build-errors on OpenWrt, where the AM_ICONV macro
+is undefined while invoking autoconfig. Later in the build, the ICONV
+LDOPTIONS are set to @LIBICONV@, failing the build.
+
+Signed-off-by: David Bauer <mail@david-bauer.net>
+---
+ configure.ac | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -70,10 +70,7 @@ AC_CHECK_DECLS([getmntent], [], [], [[#i
+ AC_CHECK_DECLS([getmntinfo], [], [], [[#include <sys/mount.h>]])
+
+ # optional iconv support
+-AC_ARG_WITH([iconv], AS_HELP_STRING([--without-iconv], [build without iconv support]))
+-if test "x$with_iconv" != "xno"; then
+- AM_ICONV
+-fi
++AC_CHECK_LIB(iconv, iconv_open)
+
+ # xxd (distributed with vim) is used in the testsuite
+ AC_CHECK_PROG([XXD_FOUND], [xxd], [yes])