aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorHuangbin Zhan <zhanhb88@gmail.com>2022-02-23 22:51:09 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-01 00:08:08 +0100
commit4a19cf3bc7caa8e1010dc5d2f6fc4411349ae6e4 (patch)
tree3d1a02cc90e7e84a366f1b87c1fbecdf1b2926bd /tools
parent40f91f6a2f633d2fbca13aa7ad6e5be1e79f5aa6 (diff)
downloadupstream-4a19cf3bc7caa8e1010dc5d2f6fc4411349ae6e4.tar.gz
upstream-4a19cf3bc7caa8e1010dc5d2f6fc4411349ae6e4.tar.bz2
upstream-4a19cf3bc7caa8e1010dc5d2f6fc4411349ae6e4.zip
tools/mkimage: update to 2022.01
- enable dot config - enable openwrt verbose - add bison as dependency to avoid failure ``` bison -oscripts/kconfig/zconf.tab.c -t -l scripts/kconfig/zconf.y bison: /builder/shared-workdir/build/staging_dir/host/share/bison/m4sugar/m4sugar.m4: cannot open: No such file or directory ``` Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/mkimage/Makefile20
-rw-r--r--tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch25
3 files changed, 30 insertions, 17 deletions
diff --git a/tools/Makefile b/tools/Makefile
index f3f9a3bf73..ec382b4122 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -62,7 +62,7 @@ $(curdir)/llvm-bpf/compile := $(curdir)/cmake/compile
$(curdir)/make-ext4fs/compile := $(curdir)/zlib/compile
$(curdir)/meson/compile := $(curdir)/ninja/compile
$(curdir)/missing-macros/compile := $(curdir)/autoconf/compile
-$(curdir)/mkimage/compile += $(curdir)/libressl/compile
+$(curdir)/mkimage/compile += $(curdir)/bison/compile $(curdir)/libressl/compile
$(curdir)/mklibs/compile := $(curdir)/libtool/compile
$(curdir)/mpc/compile := $(curdir)/mpfr/compile $(curdir)/gmp/compile
$(curdir)/mpfr/compile := $(curdir)/gmp/compile
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 5ed4107e1d..fd5dad0cd8 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,38 +7,26 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2021.10
+PKG_VERSION:=2022.01
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=cde723e19262e646f2670d25e5ec4b1b368490de950d4e26275a988c36df0bd4
+PKG_HASH:=81b4543227db228c03f8a1bf5ddbc813b0bb8f6555ce46064ef721a6fc680413
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
-define Host/Prepare
- $(Host/Prepare/Default)
- mkdir -p $(HOST_BUILD_DIR)/include/config
- touch $(HOST_BUILD_DIR)/include/config/auto.conf
- mkdir -p $(HOST_BUILD_DIR)/include/generated/
- touch $(HOST_BUILD_DIR)/include/generated/autoconf.h
-endef
-
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) \
HOSTCFLAGS="$(HOST_CFLAGS)" \
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
PKG_CONFIG_EXTRAARGS="--static" \
- no-dot-config-targets=tools-only \
- CONFIG_MKIMAGE_DTC_PATH=dtc \
- CONFIG_FIT=y \
- CONFIG_FIT_SIGNATURE=y \
- CONFIG_FIT_SIGNATURE_MAX_SIZE=0x10000000 \
- CONFIG_TOOLS_LIBCRYPTO=y \
+ V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1) \
+ tools-only_config \
tools-only
endef
diff --git a/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch b/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
new file mode 100644
index 0000000000..f2e3b9b053
--- /dev/null
+++ b/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
@@ -0,0 +1,25 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: Huangbin Zhan <zhanhb88@gmail.com>
+Date: Fri, 18 Feb 2022 14:19:23 +0800
+Subject: [PATCH] tools: disable TOOLS_FIT_FULL_CHECK
+
+ U-Boot disallows unit addresses by default. Disable TOOLS_FIT_FULL_CHECK
+ to allow at symbol in node names.
+
+https://github.com/openwrt/openwrt/commits/master/scripts/mkits.sh
+https://github.com/u-boot/u-boot/commit/3f04db891a353f4b127ed57279279f851c6b4917
+---
+ tools/Kconfig | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/tools/Kconfig
++++ b/tools/Kconfig
+@@ -31,7 +31,7 @@ config TOOLS_FIT
+ Enable FIT support in the tools builds.
+
+ config TOOLS_FIT_FULL_CHECK
+- def_bool y
++ bool "Do a full check of the FIT"
+ help
+ Do a full check of the FIT before using it in the tools builds
+