aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-02-06 20:51:40 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-01 00:08:08 +0100
commit2d5f03205ab81fcbee6ef2d2853db98a85f0ecd3 (patch)
tree3d4a1c760b4f668a436c3a2da7e31a5ed70ab152 /tools
parent03f55708cb849ff729be3ece34d949cc87de9bf9 (diff)
downloadupstream-2d5f03205ab81fcbee6ef2d2853db98a85f0ecd3.tar.gz
upstream-2d5f03205ab81fcbee6ef2d2853db98a85f0ecd3.tar.bz2
upstream-2d5f03205ab81fcbee6ef2d2853db98a85f0ecd3.zip
tools/ccache: add cmake dependency
This will be needed for the next commit as ccache's cmake dependency is satisfied by zstd currenly. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 681344a014..a13c2e82b5 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -87,7 +87,7 @@ endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
$(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
-$(curdir)/ccache/compile := $(curdir)/zstd/compile
+$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
endif
# in case there is no patch tool on the host we need to make patch tool a