aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-09-05 23:28:16 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-09-06 09:24:23 +0100
commit96a7a4738cbda4d2abfd9a4061bbfdf5c0ac2ec0 (patch)
tree5421880ecaa8b60432d102a001660e3ec3668c3f /tools
parentde0c380a5f8289839ab970e794a45f0e04a466a3 (diff)
downloadupstream-96a7a4738cbda4d2abfd9a4061bbfdf5c0ac2ec0.tar.gz
upstream-96a7a4738cbda4d2abfd9a4061bbfdf5c0ac2ec0.tar.bz2
upstream-96a7a4738cbda4d2abfd9a4061bbfdf5c0ac2ec0.zip
tools/findutils: fix build on macos
Use same fix as homebrew: https://github.com/Homebrew/homebrew-core/pull/69761 Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'tools')
-rw-r--r--tools/findutils/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/findutils/Makefile b/tools/findutils/Makefile
index c40fa6efc1..37cd897355 100644
--- a/tools/findutils/Makefile
+++ b/tools/findutils/Makefile
@@ -18,6 +18,10 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+ifeq ($(HOST_OS),Darwin)
+ HOST_CFLAGS +=-D__nonnull\\(params\\)=
+endif
+
HOST_CONFIGURE_ARGS += \
--enable-threads=pth \
--disable-rpath \