aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorDENG Qingfang <dqfext@gmail.com>2021-04-22 12:28:39 +0800
committerChristian Lamparter <chunkeey@gmail.com>2021-12-29 21:18:52 +0100
commit8166bbf6803053224a6b5807ed6d1f8391d2021c (patch)
treeb33891bc88dc731b01ef41942d983c5aae6ee5f9 /tools
parent5e2a2b086cee9a7ba9f765dbf62a62f456b6713a (diff)
downloadupstream-8166bbf6803053224a6b5807ed6d1f8391d2021c.tar.gz
upstream-8166bbf6803053224a6b5807ed6d1f8391d2021c.tar.bz2
upstream-8166bbf6803053224a6b5807ed6d1f8391d2021c.zip
ccache: update to 4.2.1
Update ccache to 4.2.1 While compiling on Gentoo, the ccache can not be compiled due to this error: /openwrt/build_dir/host/ccache-4.1/unittest/../src/third_party/doctest.h:4084:47: error: size of array 'altStackMem' is not an integral constant-expression 4084 | static char altStackMem[4 * SIGSTKSZ]; | ^ This was fixed in ccache version 4.2.1 [1] by upgrading doctest [2]. [1] https://github.com/ccache/ccache/issues/825 [2] https://github.com/doctest/doctest/issues/473 Signed-off-by: DENG Qingfang <dqfext@gmail.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [refresh patch] (cherry picked from commit 3ebfd0078d6aa4848ee8f72640266bd0390f790a) Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [improved commit message]
Diffstat (limited to 'tools')
-rw-r--r--tools/ccache/Makefile4
-rw-r--r--tools/ccache/patches/100-honour-copts.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index c69e26bd23..3db6cc0818 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=ccache
-PKG_VERSION:=4.1
+PKG_VERSION:=4.2.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
-PKG_HASH:=5fdc804056632d722a1182e15386696f0ea6c59cb4ab4d65a54f0b269ae86f99
+PKG_HASH:=9d6ba1cdefdc690401f404b747d81a9a1802b17af4235815866b7620d980477e
HOST_BUILD_PARALLEL:=1
diff --git a/tools/ccache/patches/100-honour-copts.patch b/tools/ccache/patches/100-honour-copts.patch
index e4045ef9be..0dcc6598f5 100644
--- a/tools/ccache/patches/100-honour-copts.patch
+++ b/tools/ccache/patches/100-honour-copts.patch
@@ -1,6 +1,6 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
-@@ -1654,6 +1654,7 @@ calculate_result_name(Context& ctx,
+@@ -1756,6 +1756,7 @@ calculate_result_name(Context& ctx,
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang