aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-11-29 23:40:12 +0100
committerMathias Kresin <dev@kresin.me>2018-12-12 11:01:59 +0100
commit262b885b834cecf7e7afbaca32d0a67c0b75aa44 (patch)
tree50b9bd0cc8c94b55e35cfc3f5d61acd4bb6cb2ed /tools
parent216397b8124dafafbd79afdf9f8e716b55775194 (diff)
downloadupstream-262b885b834cecf7e7afbaca32d0a67c0b75aa44.tar.gz
upstream-262b885b834cecf7e7afbaca32d0a67c0b75aa44.tar.bz2
upstream-262b885b834cecf7e7afbaca32d0a67c0b75aa44.zip
ramips: use new image build code for D-Link DCS-930 family
Drop the factory images and the firmware tool to create them. They don't work any more, since the factory image has an uImage header covering the whole kernel + rootfs. This way the uImage splitter will not be able to find the rootfs and the kernel will panic later on. The factory images were most likely added at a time the board had distinct partitions for kernel and rootfs. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'tools')
-rw-r--r--tools/firmware-utils/Makefile1
-rw-r--r--tools/firmware-utils/src/mkdcs932.c39
2 files changed, 0 insertions, 40 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 00917c3417..63df63191d 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -72,7 +72,6 @@ define Host/Compile
$(call cc,mkporayfw, -Wall)
$(call cc,mkrasimage, --std=gnu99)
$(call cc,mkhilinkfw, -lcrypto)
- $(call cc,mkdcs932, -Wall)
$(call cc,mkheader_gemtek,-lz)
$(call cc,mkrtn56uimg, -lz)
$(call cc,dgn3500sum, -Wall)
diff --git a/tools/firmware-utils/src/mkdcs932.c b/tools/firmware-utils/src/mkdcs932.c
deleted file mode 100644
index 28c67aa3b3..0000000000
--- a/tools/firmware-utils/src/mkdcs932.c
+++ /dev/null
@@ -1,39 +0,0 @@
-/*
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License,
- * version 2 as published by the Free Software Foundation.
- *
- * (C) John Crispin <blogic@openwrt.org>
- */
-
-#include <sys/types.h>
-#include <sys/stat.h>
-#include <fcntl.h>
-#include <stdio.h>
-#include <stdint.h>
-#include <unistd.h>
-#include <errno.h>
-
-int main(int argc, char **argv)
-{
- uint32_t t = 0, sum = 0x55aa55aa;
- int fd;
-
- if ((argc != 2) || ((fd = open(argv[1], O_RDWR)) == -1)) {
- fprintf(stderr, "Usage: %s input_file\n", *argv);
- return -EINVAL;
- }
-
- lseek(fd, -4, SEEK_END);
- write(fd, &t, 4);
- lseek(fd, 0, SEEK_SET);
-
- while (read(fd, &t, 4) > 0)
- sum -= t;
-
- lseek(fd, -4, SEEK_END);
- write(fd, &sum, 4);
- close(fd);
-
- return 0;
-}