aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-10-14 16:42:45 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 17:22:06 +0100
commita10c67b05727ec8b773771f60127cac39ffa90f8 (patch)
tree1f434638e88fdce641e7fc22a6cf8cb8d2b99172 /tools
parent1adb3b28a9c1b3a8302a467eaa4cb07a4c5becd4 (diff)
downloadupstream-a10c67b05727ec8b773771f60127cac39ffa90f8.tar.gz
upstream-a10c67b05727ec8b773771f60127cac39ffa90f8.tar.bz2
upstream-a10c67b05727ec8b773771f60127cac39ffa90f8.zip
tools: patch: Fix build by not modifing Makefile.am
A new test case was adding in one of the patches fixing a problem, this also included a change in the test/Makefile.am to add this test case. The build system detected a change in the Makefile.am and wants to regenerate the Makefile.in, but this fails because automake-1.15 is not installed yet. As automake depends on patch being build first, make sure we do not modify the Makefile.am. This fixes build problem seen by the build bots. Fixes: 4797dddfde6 ("patch: apply upstream cve fixes") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (backported from 759f111f8d7f2d9f5f12713fc6f48ce6422997ec)
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile1
-rw-r--r--tools/patch/patches/010-CVE-2018-1000156.patch54
2 files changed, 0 insertions, 55 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 6766d7df6e..d2b5daf18c 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -66,7 +66,6 @@ $(curdir)/bc/compile := $(curdir)/bison/compile
$(curdir)/findutils/compile := $(curdir)/bison/compile
$(curdir)/gengetopt/compile := $(curdir)/libtool/compile
$(curdir)/patchelf/compile := $(curdir)/libtool/compile
-$(curdir)/patch/compile := $(curdir)/automake/compile
$(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
$(curdir)/libressl/compile := $(curdir)/pkg-config/compile
$(curdir)/mkimage/compile += $(curdir)/libressl/compile
diff --git a/tools/patch/patches/010-CVE-2018-1000156.patch b/tools/patch/patches/010-CVE-2018-1000156.patch
index 306ba793fc..7114f82e8f 100644
--- a/tools/patch/patches/010-CVE-2018-1000156.patch
+++ b/tools/patch/patches/010-CVE-2018-1000156.patch
@@ -143,57 +143,3 @@ instead of rejecting them and carrying on.
if (ofp)
{
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -32,6 +32,7 @@ TESTS = \
- crlf-handling \
- dash-o-append \
- deep-directories \
-+ ed-style \
- empty-files \
- false-match \
- fifo \
---- /dev/null
-+++ b/tests/ed-style
-@@ -0,0 +1,41 @@
-+# Copyright (C) 2018 Free Software Foundation, Inc.
-+#
-+# Copying and distribution of this file, with or without modification,
-+# in any medium, are permitted without royalty provided the copyright
-+# notice and this notice are preserved.
-+
-+. $srcdir/test-lib.sh
-+
-+require cat
-+use_local_patch
-+use_tmpdir
-+
-+# ==============================================================
-+
-+cat > ed1.diff <<EOF
-+0a
-+foo
-+.
-+EOF
-+
-+check 'patch -e foo -i ed1.diff' <<EOF
-+EOF
-+
-+check 'cat foo' <<EOF
-+foo
-+EOF
-+
-+cat > ed2.diff <<EOF
-+1337a
-+r !echo bar
-+,p
-+EOF
-+
-+check 'patch -e foo -i ed2.diff 2> /dev/null || echo "Status: $?"' <<EOF
-+?
-+Status: 2
-+EOF
-+
-+check 'cat foo' <<EOF
-+foo
-+EOF