aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-01-21 15:15:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-01-21 15:15:47 +0000
commitef691cc0914ee4570c446ede42933fcfd1507144 (patch)
tree7afaad6455ade6fb1e3bc6517de3fa435139e0b1 /tools
parent591563a80acd799551cc0bc68a0790b3f93b0ffe (diff)
downloadupstream-ef691cc0914ee4570c446ede42933fcfd1507144.tar.gz
upstream-ef691cc0914ee4570c446ede42933fcfd1507144.tar.bz2
upstream-ef691cc0914ee4570c446ede42933fcfd1507144.zip
only build gmp and mpfr when selecting gcc-4.3.x
SVN-Revision: 14135
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 81c69b404f..768f8786c6 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,7 +9,11 @@
curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf gmp mpfr
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf
+
+ifeq ($(CONFIG_GCC_VERSION_4_3_1)$(CONFIG_GCC_VERSION_4_3_2),y)
+$(curdir)/builddirs += gmp mpfr
+endif
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install