aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-08-08 08:14:28 +0200
committerJo-Philipp Wich <jo@mein.io>2017-12-13 16:23:39 +0100
commitca7c9db47fc79908326f1159f9107577a4fddb4d (patch)
tree8e8fdaa790c375cb4601fb585c852ff0401c7703 /tools
parent75d8127338028dec1db62bfc1c3fbe5f352f5b77 (diff)
downloadupstream-ca7c9db47fc79908326f1159f9107577a4fddb4d.tar.gz
upstream-ca7c9db47fc79908326f1159f9107577a4fddb4d.tar.bz2
upstream-ca7c9db47fc79908326f1159f9107577a4fddb4d.zip
tools/pkg-config: Update to 0.29.2
* Update pkg-config to 0.29.2 * Remove patch as it's upstreamed Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net> (cherry picked from commit 965df21fd16e5966c64f207fe053ab8b6863081f)
Diffstat (limited to 'tools')
-rw-r--r--tools/pkg-config/Makefile4
-rw-r--r--tools/pkg-config/patches/001-glib-gdate-suppress-string-format-literal-warning.patch18
2 files changed, 2 insertions, 20 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index 4575c4d44e..17a8737be1 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pkg-config
-PKG_VERSION:=0.29.1
+PKG_VERSION:=0.29.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pkgconfig.freedesktop.org/releases/
-PKG_HASH:=beb43c9e064555469bd4390dcfd8030b1536e0aa103f08d7abf7ae8cac0cb001
+PKG_HASH:=6fc69c01688c9458a57eb9a1664c9aba372ccda420a02bf4429fe610e7e7d591
HOST_BUILD_PARALLEL:=1
diff --git a/tools/pkg-config/patches/001-glib-gdate-suppress-string-format-literal-warning.patch b/tools/pkg-config/patches/001-glib-gdate-suppress-string-format-literal-warning.patch
deleted file mode 100644
index 6849299c47..0000000000
--- a/tools/pkg-config/patches/001-glib-gdate-suppress-string-format-literal-warning.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/glib/glib/gdate.c
-+++ b/glib/glib/gdate.c
-@@ -2439,6 +2439,9 @@ win32_strftime_helper (const GDate *d,
- *
- * Returns: number of characters written to the buffer, or 0 the buffer was too small
- */
-+#pragma GCC diagnostic push
-+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
-+
- gsize
- g_date_strftime (gchar *s,
- gsize slen,
-@@ -2549,3 +2552,5 @@ g_date_strftime (gchar *s,
- return retval;
- #endif
- }
-+
-+#pragma GCC diagnostic pop