aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorStefan Lippers-Hollmann <s.l-h@gmx.de>2018-03-04 22:57:04 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-10 18:37:03 +0100
commit58a95f0f8ff768b43d68eed2b6a786e0f40f723b (patch)
treee6ed2bd0a2075e55c520d8de50ff5174f1ee6783 /tools
parent9bdea6a2964b9983d312b302e0fdde98c6bdc53b (diff)
downloadupstream-58a95f0f8ff768b43d68eed2b6a786e0f40f723b.tar.gz
upstream-58a95f0f8ff768b43d68eed2b6a786e0f40f723b.tar.bz2
upstream-58a95f0f8ff768b43d68eed2b6a786e0f40f723b.zip
tools/e2fsprogs: fix building on a glibc 2.27 host
The e2fsprogs host build fails on a glibc 2.27 host with make[6]: Entering directory 'build_dir/host/e2fsprogs-1.43.7/debugfs' CC create_inode.o ./../misc/create_inode.c:399:18: error: conflicting types for 'copy_file_range' static errcode_t copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file, ^~~~~~~~~~~~~~~ In file included from ./../misc/create_inode.c:19:0: /usr/include/unistd.h:1110:9: note: previous declaration of 'copy_file_range' was here ssize_t copy_file_range (int __infd, __off64_t *__pinoff, ^~~~~~~~~~~~~~~ Backport upstream commit "misc: rename copy_file_range to copy_file_chunk" 01551bdba16ab16512a01affe02ade32c41ede8a in order to fix this. Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
Diffstat (limited to 'tools')
-rw-r--r--tools/e2fsprogs/Makefile2
-rw-r--r--tools/e2fsprogs/patches/005-misc-rename-copy_file_range-to-copy_file_chunk.patch53
2 files changed, 54 insertions, 1 deletions
diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index fca90f2091..c5bdb1c0d4 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
PKG_VERSION:=1.43.3
PKG_HASH:=ce8ef1bbb0d4730f170167284fda156ac9d6bf18db2750eb94af619a81b19927
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/e2fsprogs
diff --git a/tools/e2fsprogs/patches/005-misc-rename-copy_file_range-to-copy_file_chunk.patch b/tools/e2fsprogs/patches/005-misc-rename-copy_file_range-to-copy_file_chunk.patch
new file mode 100644
index 0000000000..bd6ee81b90
--- /dev/null
+++ b/tools/e2fsprogs/patches/005-misc-rename-copy_file_range-to-copy_file_chunk.patch
@@ -0,0 +1,53 @@
+From 01551bdba16ab16512a01affe02ade32c41ede8a Mon Sep 17 00:00:00 2001
+From: Palmer Dabbelt <palmer@dabbelt.com>
+Date: Fri, 29 Dec 2017 10:19:51 -0800
+Subject: [PATCH] misc: rename copy_file_range to copy_file_chunk
+
+As of 2.27, glibc will have a copy_file_range library call to wrap the
+new copy_file_range system call. This conflicts with the function in
+misc/create_inode.c, which this patch renames _copy_file_range.
+
+Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
+Signed-off-by: Theodore Ts'o <tytso@mit.edu>
+---
+ misc/create_inode.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+--- a/misc/create_inode.c
++++ b/misc/create_inode.c
+@@ -392,7 +392,7 @@ static ssize_t my_pread(int fd, void *bu
+ }
+ #endif /* !defined HAVE_PREAD64 && !defined HAVE_PREAD */
+
+-static errcode_t copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file,
++static errcode_t copy_file_chunk(ext2_filsys fs, int fd, ext2_file_t e2_file,
+ off_t start, off_t end, char *buf,
+ char *zerobuf)
+ {
+@@ -466,7 +466,7 @@ static errcode_t try_lseek_copy(ext2_fil
+
+ data_blk = data & ~(fs->blocksize - 1);
+ hole_blk = (hole + (fs->blocksize - 1)) & ~(fs->blocksize - 1);
+- err = copy_file_range(fs, fd, e2_file, data_blk, hole_blk, buf,
++ err = copy_file_chunk(fs, fd, e2_file, data_blk, hole_blk, buf,
+ zerobuf);
+ if (err)
+ return err;
+@@ -516,7 +516,7 @@ static errcode_t try_fiemap_copy(ext2_fi
+ }
+ for (i = 0, ext = ext_buf; i < fiemap_buf->fm_mapped_extents;
+ i++, ext++) {
+- err = copy_file_range(fs, fd, e2_file, ext->fe_logical,
++ err = copy_file_chunk(fs, fd, e2_file, ext->fe_logical,
+ ext->fe_logical + ext->fe_length,
+ buf, zerobuf);
+ if (err)
+@@ -569,7 +569,7 @@ static errcode_t copy_file(ext2_filsys f
+ goto out;
+ #endif
+
+- err = copy_file_range(fs, fd, e2_file, 0, statbuf->st_size, buf,
++ err = copy_file_chunk(fs, fd, e2_file, 0, statbuf->st_size, buf,
+ zerobuf);
+ out:
+ ext2fs_free_mem(&zerobuf);