aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-26 21:11:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-26 21:11:16 +0000
commitff1ba24f51709121f92edad1fa1df38160d7d4f4 (patch)
tree232041a21cd00edf91c6d6beab1962e279d18c09 /tools
parentad5f485a4bff3f7458d80dd4775878f7081bb2b5 (diff)
downloadupstream-ff1ba24f51709121f92edad1fa1df38160d7d4f4.tar.gz
upstream-ff1ba24f51709121f92edad1fa1df38160d7d4f4.tar.bz2
upstream-ff1ba24f51709121f92edad1fa1df38160d7d4f4.zip
bison: replace the yacc script with one that does not hardcode the path (fixes #20605)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r47050 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/bison/Makefile5
-rwxr-xr-xtools/bison/scripts/yacc2
2 files changed, 7 insertions, 0 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 10d8720484..256512116f 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -23,4 +23,9 @@ define Host/Clean
$(call Host/Clean/Default)
endef
+define Host/Install
+ $(call Host/Install/Default)
+ $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
$(eval $(call HostBuild))
diff --git a/tools/bison/scripts/yacc b/tools/bison/scripts/yacc
new file mode 100755
index 0000000000..8f73e26fb1
--- /dev/null
+++ b/tools/bison/scripts/yacc
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec bison -y "$@"