aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-26 10:39:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-26 10:39:41 +0000
commit70a7dccd231a6354c887b9e5b127bc1de1201926 (patch)
tree6934d85450f868e0062c4d4385270dd7a4151f44 /tools
parent43fe09ee77e73944d29805ff2eb266614b570708 (diff)
downloadupstream-70a7dccd231a6354c887b9e5b127bc1de1201926.tar.gz
upstream-70a7dccd231a6354c887b9e5b127bc1de1201926.tar.bz2
upstream-70a7dccd231a6354c887b9e5b127bc1de1201926.zip
mkimage: cross compile fix: pass HOST_*FLAGS in to uboot's makefile
The HOST_*FLAGS are for compiling programs which will run on the machine that is running the build. Setting these flags is frequently required for unusual cross-compiles. Signed-off-by: Lawrence D'Anna <larry@elder-gods.org> Backport of r46424 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47651 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/mkimage/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index a65eedfcc6..f73cc56318 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -31,8 +31,8 @@ define Host/Prepare
endef
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) defconfig
- $(MAKE) -C $(HOST_BUILD_DIR) tools-only
+ $(MAKE) -C $(HOST_BUILD_DIR) defconfig HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
+ $(MAKE) -C $(HOST_BUILD_DIR) tools-only HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
endef
define Host/Install