aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-20 06:29:38 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-20 06:29:38 +0000
commit4cd9d06c9c6b8476e0a83ac819aab91757339311 (patch)
treebc419cc84a396ab6c71513e7baa55e25d447311b /tools
parenta7621732071e685191008d0f20ea849b1a743ac1 (diff)
downloadupstream-4cd9d06c9c6b8476e0a83ac819aab91757339311.tar.gz
upstream-4cd9d06c9c6b8476e0a83ac819aab91757339311.tar.bz2
upstream-4cd9d06c9c6b8476e0a83ac819aab91757339311.zip
firmware-utils: restore compilation of mkhilinkfw.
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42989 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile1
-rw-r--r--tools/firmware-utils/Makefile4
2 files changed, 3 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 562925160f..9879be1b2c 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -72,6 +72,7 @@ $(curdir)/b43-tools/compile := $(curdir)/bison/install
$(curdir)/padjffs2/compile := $(curdir)/findutils/install
$(curdir)/cloog/compile := $(curdir)/ppl/install
$(curdir)/bc/compile := $(curdir)/bison/install
+$(curdir)/firmware-utils/compile := package/openssl/host/install
ifneq ($(CONFIG_CCACHE),)
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 4bb53cbb3f..65b7c1530e 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
define cc
- $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) $(HOST_LDFLAGS) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
endef
define Host/Compile
@@ -65,7 +65,7 @@ define Host/Compile
$(call cc,fix-u-media-header cyg_crc32,-Wall)
$(call cc,hcsmakeimage bcmalgo)
$(call cc,mkporayfw, -Wall)
- #$(call cc,mkhilinkfw, -lcrypto)
+ $(call cc,mkhilinkfw, -lcrypto)
$(call cc,mkdcs932, -Wall)
$(call cc,mkheader_gemtek,-lz)
$(call cc,mkrtn56uimg, -lz)