aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-11-20 22:09:11 +0000
committerLuka Perkov <luka@openwrt.org>2013-11-20 22:09:11 +0000
commite73e2e4ca0f2ae7df5371820d78092fa0b4241e6 (patch)
tree46b0f862eb203e11931ac840823f21100842aa12 /tools
parentd011f5cde3a108c3ca9db6de088f12d517d750f7 (diff)
downloadupstream-e73e2e4ca0f2ae7df5371820d78092fa0b4241e6.tar.gz
upstream-e73e2e4ca0f2ae7df5371820d78092fa0b4241e6.tar.bz2
upstream-e73e2e4ca0f2ae7df5371820d78092fa0b4241e6.zip
[tools] pkg-config: fix occasional install problem
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38886 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/pkg-config/Makefile2
-rw-r--r--tools/pkg-config/patches/001-fix-package-rebuild.patch22
2 files changed, 23 insertions, 1 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index 6bd53f8610..0edc807e9d 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
diff --git a/tools/pkg-config/patches/001-fix-package-rebuild.patch b/tools/pkg-config/patches/001-fix-package-rebuild.patch
new file mode 100644
index 0000000000..54f549c076
--- /dev/null
+++ b/tools/pkg-config/patches/001-fix-package-rebuild.patch
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -39,7 +39,7 @@
+ if HOST_TOOL
+ host_tool = $(host)-pkg-config$(EXEEXT)
+ install-exec-hook:
+- cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++ cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ uninstall-hook:
+ cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
+ endif
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1093,7 +1093,7 @@
+ uninstall-man1
+
+ @HOST_TOOL_TRUE@install-exec-hook:
+-@HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++@HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ @HOST_TOOL_TRUE@uninstall-hook:
+ @HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
+