aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-15 14:17:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-15 14:17:40 +0000
commitbe1b98377be2ecaab8a275557ae673e4e9f00c3c (patch)
tree97da079e51103d599058e83c64521770064d9370 /tools
parent3c515ed36549a99c7de95ae0edffc16601b8ecff (diff)
downloadupstream-be1b98377be2ecaab8a275557ae673e4e9f00c3c.tar.gz
upstream-be1b98377be2ecaab8a275557ae673e4e9f00c3c.tar.bz2
upstream-be1b98377be2ecaab8a275557ae673e4e9f00c3c.zip
tools/xz enable parallel builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33431 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/xz/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
index 7298630882..383cdcdfd4 100644
--- a/tools/xz/Makefile
+++ b/tools/xz/Makefile
@@ -13,12 +13,14 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://tukaani.org/xz
PKG_MD5SUM:=741cd3a5f64b23b7bac56ec5b2258715
+HOST_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/host-build.mk
HOST_LDFLAGS += $(HOST_STATIC_LINKING)
define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
+ $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
endef