aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-10 10:44:58 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-10 10:44:58 +0000
commit9ea24821946bf3dd2113ed802d4101a7ec8e980b (patch)
treeebb04bef041d35940b8fa98afb82c7d9e23e8b30 /tools
parentea9e5d72aad4e2c67a7e06b36f7e91063867fcbe (diff)
downloadupstream-9ea24821946bf3dd2113ed802d4101a7ec8e980b.tar.gz
upstream-9ea24821946bf3dd2113ed802d4101a7ec8e980b.tar.bz2
upstream-9ea24821946bf3dd2113ed802d4101a7ec8e980b.zip
[tools] revert r24407, its already packaged in the xorg feed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24409 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/xorg-macros/Makefile34
2 files changed, 0 insertions, 36 deletions
diff --git a/tools/Makefile b/tools/Makefile
index b94ce4b535..9306601c7a 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -17,7 +17,6 @@ endif
tools-y += m4 autoconf automake bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += xorg-macros
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_TARGET_x86) += qemu
ifneq ($(CONFIG_TARGET_ar71xx),)
@@ -47,7 +46,6 @@ $(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
$(curdir)/mkimage/compile := $(curdir)/sed/install
$(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
$(curdir)/upslug2/compile := $(curdir)/automake/install
-$(curdir)/xorg-macros/compile := $(curdir)/autoconf/install
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)
diff --git a/tools/xorg-macros/Makefile b/tools/xorg-macros/Makefile
deleted file mode 100644
index 020dadb079..0000000000
--- a/tools/xorg-macros/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=xorg-macros
-PKG_VERSION:=1.11.0
-
-PKG_SOURCE:=util-macros-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://cgit.freedesktop.org/xorg/util/macros/snapshot/
-PKG_MD5SUM:=2bb2645cfc2cc6768dd46f9406cab1d7
-
-HOST_BUILD_DIR:=$(BUILD_DIR)/util-macros-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Compile
- ( cd $(HOST_BUILD_DIR); ./autogen.sh )
-endef
-
-define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR)/host/share/aclocal
- $(INSTALL_DATA) $(HOST_BUILD_DIR)/xorg-macros.m4 $(STAGING_DIR)/host/share/aclocal/
-endef
-
-define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
-endef
-
-$(eval $(call HostBuild))