aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 21:41:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 21:41:44 +0000
commit85d7e4c4099b1524a110948edd3cfdf6a491ec6e (patch)
treed59a909c919be9155a0446f21096fbadceed82a9 /tools
parentcc0dd3bd4686634099d1ada3a8f9a283b0c11697 (diff)
downloadupstream-85d7e4c4099b1524a110948edd3cfdf6a491ec6e.tar.gz
upstream-85d7e4c4099b1524a110948edd3cfdf6a491ec6e.tar.bz2
upstream-85d7e4c4099b1524a110948edd3cfdf6a491ec6e.zip
[tools] sed: unconditionally disable SELinux, NLS and ACL support (#12007)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33119 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/sed/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/sed/Makefile b/tools/sed/Makefile
index 6c0c948c5e..019df953d6 100644
--- a/tools/sed/Makefile
+++ b/tools/sed/Makefile
@@ -17,6 +17,13 @@ export SED:=
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_ARGS += \
+ --disable-acl \
+ --disable-nls \
+
+HOST_CONFIGURE_VARS += \
+ ac_cv_search_setfilecon=no \
+
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="-static"
endef