aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:08 +0000
commit0ddff5a4ea24ba4185b6a1469cd7e7cd11ce1841 (patch)
tree69262cda089d351d5bcab9d0f47c78882822d78c /tools
parent897b0f59ab49386295d19bcc7176c86f354056f9 (diff)
downloadupstream-0ddff5a4ea24ba4185b6a1469cd7e7cd11ce1841.tar.gz
upstream-0ddff5a4ea24ba4185b6a1469cd7e7cd11ce1841.tar.bz2
upstream-0ddff5a4ea24ba4185b6a1469cd7e7cd11ce1841.zip
[tools] firmware-utils: link statically
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33117 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/firmware-utils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 05b588f3b5..640dd23ee5 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
define cc
- $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h -static -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
endef
define Host/Compile