aboutsummaryrefslogtreecommitdiffstats
path: root/tools/tar
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-28 01:23:56 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 00:33:22 +0200
commita63805b25f99e609d575ee920baae269fb58794c (patch)
tree3d7090484571e2b300efdd658033378c250a485e /tools/tar
parentf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (diff)
downloadupstream-a63805b25f99e609d575ee920baae269fb58794c.tar.gz
upstream-a63805b25f99e609d575ee920baae269fb58794c.tar.bz2
upstream-a63805b25f99e609d575ee920baae269fb58794c.zip
tools: add Host/Uninstall where possible
This cleans staging_dir when calling tool/x/clean. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/tar')
-rw-r--r--tools/tar/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/tar/Makefile b/tools/tar/Makefile
index f1dfc11f93..47aad9ec6e 100644
--- a/tools/tar/Makefile
+++ b/tools/tar/Makefile
@@ -28,4 +28,8 @@ HOST_CONFIGURE_ARGS += \
--disable-acl \
--disable-nls
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
+endef
+
$(eval $(call HostBuild))