aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sstrip/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 20:51:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-13 20:51:49 +0000
commit5b2f37e0cd7ef98a06611fb42b947d8984f0e12a (patch)
treed993cf48b4d89166701fe2f33976389d7634235d /tools/sstrip/Makefile
parent79c3b44dbfbd6fb819a0daf64c2b797c29b04d85 (diff)
parent4b8e77121f1bcca81025c3fcb7b87bf869bef7f9 (diff)
downloadupstream-5b2f37e0cd7ef98a06611fb42b947d8984f0e12a.tar.gz
upstream-5b2f37e0cd7ef98a06611fb42b947d8984f0e12a.tar.bz2
upstream-5b2f37e0cd7ef98a06611fb42b947d8984f0e12a.zip
finally move buildroot-ng to trunk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5059 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/sstrip/Makefile')
-rw-r--r--tools/sstrip/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/sstrip/Makefile b/tools/sstrip/Makefile
new file mode 100644
index 0000000000..4e409e0d8d
--- /dev/null
+++ b/tools/sstrip/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
+
+OS:=$(shell uname)
+ifeq ($(HOST_OS),Darwin)
+ CFLAGS += -I./include
+endif
+
+define Build/Compile
+ $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+endef
+
+define Build/Install
+ mkdir -p $(STAGING_DIR)/bin
+ $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR)/bin/
+endef
+
+define Build/Clean
+ rm -f $(STAGING_DIR)/bin/sstrip
+endef
+
+$(eval $(call HostBuild))