aboutsummaryrefslogtreecommitdiffstats
path: root/tools/squashfs4/patches/110-allow_static_liblzma.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-03 01:02:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-03 01:02:00 +0000
commite6aa1cab006268be2de19e4c82b5eff37516405c (patch)
treea1bcdf9e6680ecd5a8646ab4923d8d43f9971437 /tools/squashfs4/patches/110-allow_static_liblzma.patch
parentb9e759ae5a98e3f22e2865518bd3f076af56be61 (diff)
downloadupstream-e6aa1cab006268be2de19e4c82b5eff37516405c.tar.gz
upstream-e6aa1cab006268be2de19e4c82b5eff37516405c.tar.bz2
upstream-e6aa1cab006268be2de19e4c82b5eff37516405c.zip
tools/squashfs4: update to version 4.2 (adds support for xz compression)
Based on a patch by Jonas Gorski SVN-Revision: 26422
Diffstat (limited to 'tools/squashfs4/patches/110-allow_static_liblzma.patch')
-rw-r--r--tools/squashfs4/patches/110-allow_static_liblzma.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/squashfs4/patches/110-allow_static_liblzma.patch b/tools/squashfs4/patches/110-allow_static_liblzma.patch
new file mode 100644
index 0000000000..9a3a744184
--- /dev/null
+++ b/tools/squashfs4/patches/110-allow_static_liblzma.patch
@@ -0,0 +1,30 @@
+--- a/squashfs-tools/Makefile
++++ b/squashfs-tools/Makefile
+@@ -129,7 +129,6 @@ ifeq ($(LZMA_XZ_SUPPORT),1)
+ CFLAGS += -DLZMA_SUPPORT
+ MKSQUASHFS_OBJS += lzma_xz_wrapper.o
+ UNSQUASHFS_OBJS += lzma_xz_wrapper.o
+-LIBS += -llzma
+ COMPRESSORS += lzma
+ endif
+
+@@ -137,10 +136,18 @@ ifeq ($(XZ_SUPPORT),1)
+ CFLAGS += -DXZ_SUPPORT
+ MKSQUASHFS_OBJS += xz_wrapper.o
+ UNSQUASHFS_OBJS += xz_wrapper.o
+-LIBS += -llzma
+ COMPRESSORS += xz
+ endif
+
++ifneq ($(LZMA_XZ_SUPPORT)$(XZ_SUPPORT),)
++ifneq ($(LZMA_LIB),)
++MKSQUASHFS_OBJS += $(LZMA_LIB)
++UNSQUASHFS_OBJS += $(LZMA_LIB)
++else
++LIBS += -llzma
++endif
++endif
++
+ ifeq ($(LZO_SUPPORT),1)
+ CFLAGS += -DLZO_SUPPORT
+ ifdef LZO_DIR