aboutsummaryrefslogtreecommitdiffstats
path: root/tools/squashfs4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:52 +0000
commite60a53c833c33f1be07664acd9a04fa7c2e36c53 (patch)
tree0bf2a188a93217e3a1076bb089b84ec44fafd191 /tools/squashfs4/Makefile
parentefa8655f20c29df2755e4e01520e3c86a450c28c (diff)
downloadupstream-e60a53c833c33f1be07664acd9a04fa7c2e36c53.tar.gz
upstream-e60a53c833c33f1be07664acd9a04fa7c2e36c53.tar.bz2
upstream-e60a53c833c33f1be07664acd9a04fa7c2e36c53.zip
squashfs4: add lzma support (kernel support still missing)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15884 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/squashfs4/Makefile')
-rw-r--r--tools/squashfs4/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
index f172d3bc6b..ddbca11403 100644
--- a/tools/squashfs4/Makefile
+++ b/tools/squashfs4/Makefile
@@ -20,6 +20,9 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ USE_LZMA=1 \
+ LZMA_CFLAGS="-I$(STAGING_DIR_HOST)/include -DUSE_LZMA" \
+ LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
mksquashfs unsquashfs
endef