aboutsummaryrefslogtreecommitdiffstats
path: root/tools/squashfs3-lzma/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-02-06 23:07:24 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-02-18 21:11:36 +0100
commit01262c921c7cbafc9a32b912e42c58982f47725c (patch)
tree8c5fee2472391ffc9fd67ccf5f2e8960161a1b8c /tools/squashfs3-lzma/Makefile
parent78dc8e2b13df439db92f233fe61d75959ffb57a6 (diff)
downloadupstream-01262c921c7cbafc9a32b912e42c58982f47725c.tar.gz
upstream-01262c921c7cbafc9a32b912e42c58982f47725c.tar.bz2
upstream-01262c921c7cbafc9a32b912e42c58982f47725c.zip
tools/squashfs: rename to squashfs3-lzma
The name of squashfs is confusing since in reality it's a really old version using an old lzma library. This tools is used for old ath79 netgear target and to produde a fake squasfs3 image needed for some specific bootloader from some OEM (AVM for example) Rename squashfs tool to squasfs3-lzma to better describe it. Rename the installed bin from mksquashfs-lzma to mksquashfs3-lzma. Use tar transform to migrate the root directory in tar to the new naming. Drop redundant PKG_CAT variable not needed anymore. Also update any user of this tool. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/squashfs3-lzma/Makefile')
-rw-r--r--tools/squashfs3-lzma/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/tools/squashfs3-lzma/Makefile b/tools/squashfs3-lzma/Makefile
new file mode 100644
index 0000000000..b02018629e
--- /dev/null
+++ b/tools/squashfs3-lzma/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=squashfs3-lzma
+PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
+PKG_VERSION:=3.0
+
+PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/squashfs
+PKG_HASH:=39dbda43cf118536deb746c7730b468702d514a19f4cfab73b710e32908ddf20
+
+# Tar directory is squashfs3.0 that conflict with any pattern
+# currently using for host tools. (PKG_NAME-PKG_VERSION)
+# Also this got renamed to a more correct name
+# from squashfs to squashfs3-lzma.
+# Use tar transform to rename the root directory to this new
+# name.
+TAR_OPTIONS+=--transform=s/^squashfs/$(PKG_NAME)-/
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ CC="$(HOSTCC)" \
+ CFLAGS="$(HOST_CFLAGS) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I." \
+ CXX="$(CXX)" \
+ LZMAPATH=$(STAGING_DIR_HOST)/lib \
+ mksquashfs-lzma unsquashfs-lzma
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs-lzma $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs-lzma $(STAGING_DIR_HOST)/bin/unsquashfs3-lzma
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma
+ rm -f $(STAGING_DIR_HOST)/bin/unsquashfs3-lzma
+endef
+
+$(eval $(call HostBuild))