aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sdcc/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-24 16:21:30 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-24 16:21:30 +0000
commit473b747b1afaa695792bb724b81644a5b4c4d37b (patch)
tree67dbc00652b941f8210a5cfdc2bff7f1969df944 /tools/sdcc/Makefile
parentd6c62705fb73764fc22e2e92caca245ec7817448 (diff)
downloadupstream-473b747b1afaa695792bb724b81644a5b4c4d37b.tar.gz
upstream-473b747b1afaa695792bb724b81644a5b4c4d37b.tar.bz2
upstream-473b747b1afaa695792bb724b81644a5b4c4d37b.zip
sdcc: drop tool, it is not used since r31227
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38167
Diffstat (limited to 'tools/sdcc/Makefile')
-rw-r--r--tools/sdcc/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/tools/sdcc/Makefile b/tools/sdcc/Makefile
deleted file mode 100644
index 3210bb3e76..0000000000
--- a/tools/sdcc/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=sdcc
-PKG_VERSION:=3.0.0
-
-PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=20fbd49a3421e09fe65577c45524c89e
-
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
-HOST_CONFIGURE_ARGS += \
- --disable-ucsim \
- --enable-packihx \
- --enable-sdcpp \
- --disable-sdcdb \
- --disable-gbz80-port \
- --disable-z80-port \
- --disable-ds390-port \
- --disable-ds400-port \
- --disable-pic-port \
- --disable-pic16-port \
- --disable-hc08-port \
- --disable-avr-port \
- --disable-xa51-port \
- --enable-mcs51-port \
- --enable-device-lib \
-
-define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
-endef
-
-$(eval $(call HostBuild))