aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-28 11:19:31 -0800
committerPetr Štetiar <ynezz@true.cz>2020-03-01 21:36:00 +0100
commit867298cf47ab505dee738fc653b90fa0bc2d0428 (patch)
treeec71d1775038e4091c666df2849f4b04d533b7c8 /tools/pkg-config
parentaf878339ae28391dd7509cd27496fa4ca8d2a339 (diff)
downloadupstream-867298cf47ab505dee738fc653b90fa0bc2d0428.tar.gz
upstream-867298cf47ab505dee738fc653b90fa0bc2d0428.tar.bz2
upstream-867298cf47ab505dee738fc653b90fa0bc2d0428.zip
tools/pkg-config: Replace with pkgconf
pkgconf is a newer, actively maintained implementation of pkg-config that supports more aspects of the pkg-config file specification and provides a library interface that applications can use to incorporate intelligent handling of pkg-config files into themselves (such as build file generators, IDEs, and compilers). Through its pkg-config compatibility interface (activated when it is run as "pkg-config"), it also can completely replace the original implementation. It is also lighterweight and does not require glib2, as pkg-config does. On other distros, pkgconf is symlinked to pkg-config. For simplicity here, it is renamed to pkg-config.real, as in the original package. Initial results have been positive. As before, pkgconf works as long as the pkg-config files point to the proper paths. Signed-off-by: Rosen Penev <rosenp@gmail.com> [backported upstream fix for Meson] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile39
-rwxr-xr-xtools/pkg-config/files/pkg-config3
2 files changed, 0 insertions, 42 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
deleted file mode 100644
index 17a8737be1..0000000000
--- a/tools/pkg-config/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2006-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pkg-config
-PKG_VERSION:=0.29.2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pkgconfig.freedesktop.org/releases/
-PKG_HASH:=6fc69c01688c9458a57eb9a1664c9aba372ccda420a02bf4429fe610e7e7d591
-
-HOST_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/host-build.mk
-
-unexport PKG_CONFIG
-
-HOST_CONFIGURE_ARGS += --with-internal-glib
-
-ifeq ($(HOST_OS),Darwin)
-HOST_LDFLAGS += -framework CoreFoundation -framework Carbon
-endif
-
-define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install
- mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
- $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
-endef
-
-define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/pkg-config/files/pkg-config b/tools/pkg-config/files/pkg-config
deleted file mode 100755
index 82cc74ffcb..0000000000
--- a/tools/pkg-config/files/pkg-config
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-pkg-config.real --define-variable=prefix=${STAGING_PREFIX} --define-variable=exec_prefix=${STAGING_PREFIX} --define-variable=bindir=${STAGING_PREFIX}/bin $@