aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtd-utils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-02-24 23:02:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-02-24 23:02:38 +0000
commit81aeef89072811a5e81d0cb4d83c44c93b1cdab2 (patch)
tree635c552ca235e6c8d44b4e7b41772f0424d6961c /tools/mtd-utils/Makefile
parent93aae29643436528ff33a425a80a93fd09f1a1b4 (diff)
downloadupstream-81aeef89072811a5e81d0cb4d83c44c93b1cdab2.tar.gz
upstream-81aeef89072811a5e81d0cb4d83c44c93b1cdab2.tar.bz2
upstream-81aeef89072811a5e81d0cb4d83c44c93b1cdab2.zip
mtd-utils: do not try to compile in support for ubifs ioctls and extended flags - some linux distros do not support this
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19846 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mtd-utils/Makefile')
-rw-r--r--tools/mtd-utils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index 45a61ab3c3..45bceaf837 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -21,7 +21,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
-CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib
+CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib -DNO_NATIVE_SUPPORT
ifneq ($(HOST_OS),Linux)
CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h -I$(CURDIR)/include -include fls.h
endif