aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtd-utils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:23 +0000
commit5eee701769d160d3af59fc250e0049fb92352374 (patch)
tree2c8ad1c335e660a8f04bec22794bada815b7df03 /tools/mtd-utils/Makefile
parentcd6e7223fd568526f0bea3cce943de2c7b8b98b8 (diff)
downloadupstream-5eee701769d160d3af59fc250e0049fb92352374.tar.gz
upstream-5eee701769d160d3af59fc250e0049fb92352374.tar.bz2
upstream-5eee701769d160d3af59fc250e0049fb92352374.zip
add ubinize to the mtd-utils build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16457 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mtd-utils/Makefile')
-rw-r--r--tools/mtd-utils/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index a74c94155c..06be6c7b8d 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -36,10 +36,16 @@ define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) \
$(MTD_MAKEOPTS) \
TARGETS=mkfs.jffs2
+ $(MAKE) -C $(HOST_BUILD_DIR)/ubi-utils \
+ $(MTD_MAKEOPTS) \
+ TARGETS=ubinize
endef
define Host/Install
- $(CP) $(HOST_BUILD_DIR)/mkfs.jffs2 $(STAGING_DIR_HOST)/bin/
+ $(CP) \
+ $(HOST_BUILD_DIR)/mkfs.jffs2 \
+ $(HOST_BUILD_DIR)/ubinize \
+ $(STAGING_DIR_HOST)/bin/
endef
define Host/Clean