aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mm-macros
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-15 22:27:43 -0700
committerPaul Spooren <mail@aparcar.org>2021-09-16 16:27:32 -1000
commit4b898afdd2fd9dbbc99dbedca0d50785e3ec063d (patch)
tree1949015edd42cf89f438376dcfc7abeea78a2e38 /tools/mm-macros
parenta46fa5c3a7fb6cdfd20969a38b9b0ffe8b314d1b (diff)
downloadupstream-4b898afdd2fd9dbbc99dbedca0d50785e3ec063d.tar.gz
upstream-4b898afdd2fd9dbbc99dbedca0d50785e3ec063d.tar.bz2
upstream-4b898afdd2fd9dbbc99dbedca0d50785e3ec063d.zip
tools/mm-macros: remove
ccaaab1c048159611e93a181dde740f49fa12483 says that this is in the codebase because of libsigc++, which is not in the codebase anymore. Neither in base nor in packages. It doesn't seem to be needed by anything else either. GNOME packages have transitioned to using meson, which does not use m4 files. Tested local compile with CONFIG_ALL. No problems seen. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/mm-macros')
-rw-r--r--tools/mm-macros/Makefile33
1 files changed, 0 insertions, 33 deletions
diff --git a/tools/mm-macros/Makefile b/tools/mm-macros/Makefile
deleted file mode 100644
index 071563378f..0000000000
--- a/tools/mm-macros/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2010-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mm-macros
-PKG_VERSION:=1.0.0
-
-PKG_SOURCE_URL:=@GNOME/mm-common/1.0
-PKG_SOURCE:=mm-common-$(PKG_VERSION).tar.xz
-PKG_HASH:=b97d9b041e5952486cab620b44ab09f6013a478f43b6699ae899b8a4da189cd4
-
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mm-common-$(PKG_VERSION)
-
-HOST_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
- $(INSTALL_DATA) $(HOST_BUILD_DIR)/macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
-endef
-
-define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
-endef
-
-$(eval $(call HostBuild))