aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
authorHuangbin Zhan <zhanhb88@gmail.com>2021-11-26 08:38:31 +0800
committerChristian Lamparter <chunkeey@gmail.com>2021-12-27 13:51:41 +0100
commitb6385a36680b6924239cbc6766a253cab45db8d9 (patch)
tree2f7d0b90461ed2478538bd89a6357ff6e8ad0b8c /tools/mkimage/Makefile
parenta0ad1f36f0afe5c29dde6a66bd5d89fa4842874f (diff)
downloadupstream-b6385a36680b6924239cbc6766a253cab45db8d9.tar.gz
upstream-b6385a36680b6924239cbc6766a253cab45db8d9.tar.bz2
upstream-b6385a36680b6924239cbc6766a253cab45db8d9.zip
tools/mkimage: update to 2021.10
Changelog: - upstream now needs OpenSSL in order to be able to sign FITs. See: commit cb9faa6f98ae ("tools: Use a single target-independent config to enable OpenSSL") - removes upstream patches. Link: https://github.com/u-boot/u-boot/commit/cb9faa6f98ae56d70d59505dad290dd3d381cb7b Tested-by: Sergey V. Lobanov <sergey@lobanov.in> Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 1eb713a22a..5ed4107e1d 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2021.01
+PKG_VERSION:=2021.10
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=b407e1510a74e863b8b5cb42a24625344f0e0c2fc7582d8c866bd899367d0454
+PKG_HASH:=cde723e19262e646f2670d25e5ec4b1b368490de950d4e26275a988c36df0bd4
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -38,6 +38,7 @@ define Host/Compile
CONFIG_FIT=y \
CONFIG_FIT_SIGNATURE=y \
CONFIG_FIT_SIGNATURE_MAX_SIZE=0x10000000 \
+ CONFIG_TOOLS_LIBCRYPTO=y \
tools-only
endef