aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkelfimage/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-05-17 10:33:46 +0000
committerJohn Crispin <blogic@openwrt.org>2011-05-17 10:33:46 +0000
commitd5449e1acce9c787f49f5a93837be6584a2ffcc5 (patch)
tree6093fed7d6b1fe581940b8768bd8441e2b8b53b5 /tools/mkelfimage/Makefile
parente5d13905914c53bdc7416dcb54ce0e2d0e14bf59 (diff)
downloadupstream-d5449e1acce9c787f49f5a93837be6584a2ffcc5.tar.gz
upstream-d5449e1acce9c787f49f5a93837be6584a2ffcc5.tar.bz2
upstream-d5449e1acce9c787f49f5a93837be6584a2ffcc5.zip
[tools]
* adds mkelfimage git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26918 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mkelfimage/Makefile')
-rw-r--r--tools/mkelfimage/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/mkelfimage/Makefile b/tools/mkelfimage/Makefile
new file mode 100644
index 0000000000..75cff88d93
--- /dev/null
+++ b/tools/mkelfimage/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mkelfimage
+PKG_VERSION:=2.7
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/m/mkelfimage/
+PKG_MD5SUM:=e505cb87e9c0cdc44cf03d2c4ea8c74b
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/objdir/sbin/mkelfImage $(STAGING_DIR_HOST)/bin
+endef
+
+$(eval $(call HostBuild))