aboutsummaryrefslogtreecommitdiffstats
path: root/tools/meson/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-04 18:48:30 -0700
committerPaul Spooren <mail@aparcar.org>2021-10-07 14:09:40 -1000
commitc2222f74c8eff592032473ab2d29d5e8febace63 (patch)
treef15fb0d9c14946785d6731d1c80bf8680d56d913 /tools/meson/Makefile
parente4e410733f3b0cad09d3a235eec0b04f4068c331 (diff)
downloadupstream-c2222f74c8eff592032473ab2d29d5e8febace63.tar.gz
upstream-c2222f74c8eff592032473ab2d29d5e8febace63.tar.bz2
upstream-c2222f74c8eff592032473ab2d29d5e8febace63.zip
tools/meson: update to 0.59.2
Update install procedure based on upstream feedback. Normally, meson is to be installed with pip. But as pip is not mandated by the build system, it cannot be used. Upstream provides a nice script to pack meson automatically. Moved src/ to files/. No need to copy to BUILD_DIR. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/meson/Makefile')
-rw-r--r--tools/meson/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index bae89654a5..0cf0efba47 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.59.1
+PKG_VERSION:=0.59.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=db586a451650d46bbe10984a87b79d9bcdc1caebf38d8e189f8848f8d502356d
+PKG_HASH:=13dee549a7ba758b7e33ce7719f28d1d337a98d10d378a4779ccc996f5a2fc49
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
@@ -20,8 +20,11 @@ define Host/Compile
endef
define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+ $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --interpreter $(STAGING_DIR_HOST)/bin/$(PYTHON) --outfile $(STAGING_DIR_HOST)/bin/meson
$(INSTALL_DIR) $(STAGING_DIR_HOST)/lib/meson
- $(CP) $(HOST_BUILD_DIR)/* $(STAGING_DIR_HOST)/lib/meson/
+ $(INSTALL_CONF) files/openwrt-cross.txt.in $(STAGING_DIR_HOST)/lib/meson/
+ $(INSTALL_CONF) files/openwrt-native.txt.in $(STAGING_DIR_HOST)/lib/meson/
endef
define Host/Clean