aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libtool/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:10 +0000
commit7228b245ffa785826e2e22e62dd80ff99f633216 (patch)
treeac15e815765ffa4d8e244437ed673547b65f9ce3 /tools/libtool/Makefile
parent5aa01e2480552f19e6bc14e4506351b268f22f73 (diff)
downloadupstream-7228b245ffa785826e2e22e62dd80ff99f633216.tar.gz
upstream-7228b245ffa785826e2e22e62dd80ff99f633216.tar.bz2
upstream-7228b245ffa785826e2e22e62dd80ff99f633216.zip
tools: bootstrap libtool to pickup the correct in-tree automake
Also fix 000-relocatable.patch to avoid accidential sed invocations in bootstrap. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43959 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/libtool/Makefile')
-rw-r--r--tools/libtool/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index cb6cf4a5c7..9fab8d94fd 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -20,6 +20,12 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_VARS += \
lt_cv_sys_dlsearch_path=""
+define Host/Prepare
+ $(call Host/Prepare/Default)
+ (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
+ (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) ./bootstrap)
+endef
+
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
$(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool