aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libressl
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-07-20 19:14:10 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-31 18:46:23 +0200
commitb2e2deeb8dfa3c1a620cb5d1d0d54eccff85d2c0 (patch)
treea25ca2221cfccb0f739d382cbdb46895083a1f69 /tools/libressl
parent3aa18f71f9c8a5447bdd2deda4e681175338164f (diff)
downloadupstream-b2e2deeb8dfa3c1a620cb5d1d0d54eccff85d2c0.tar.gz
upstream-b2e2deeb8dfa3c1a620cb5d1d0d54eccff85d2c0.tar.bz2
upstream-b2e2deeb8dfa3c1a620cb5d1d0d54eccff85d2c0.zip
tools/libressl: ensure PIC-only object compilation
Line up configure arguments for cleaner git diff and editing and grepping. LibreSSL must be built with PIC, and has the flags for it already in CFLAGS. Add the configure option native to LibreSSL to use only PIC in objects, which further enforces that each object in the library has the PIC flag to prevent a mixture of PIC / non-PIC objects within it. Ref: 96a940308 ("tools: libressl: always build as PIC") Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/libressl')
-rw-r--r--tools/libressl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
index 236a7c2c30..aecc788972 100644
--- a/tools/libressl/Makefile
+++ b/tools/libressl/Makefile
@@ -24,9 +24,15 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOSTCC := $(HOSTCC_NOCACHE)
-HOST_CONFIGURE_ARGS += --enable-static --disable-shared --disable-tests
+
HOST_CFLAGS += $(HOST_FPIC)
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-pic \
+ --disable-tests
+
ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
HOST_CONFIGURE_ARGS += --disable-asm
endif