aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2017-10-03 18:12:27 +0200
committerMathias Kresin <dev@kresin.me>2017-10-06 08:28:41 +0200
commit10324fcb3992cdf40db651ae6ad0b3cda670d81b (patch)
tree7fda55cadd19de594f361d0f37642336c1c883ae /tools/firmware-utils/Makefile
parent10832c8e12da66b97c266d493b236ab2c804ea70 (diff)
downloadupstream-10324fcb3992cdf40db651ae6ad0b3cda670d81b.tar.gz
upstream-10324fcb3992cdf40db651ae6ad0b3cda670d81b.tar.bz2
upstream-10324fcb3992cdf40db651ae6ad0b3cda670d81b.zip
tools/firmware-utils: mktplinkfw regroup duplicate code
This patch carves out the duplicated code of mktplinfw.c and mktplinkfw2.c and moves it to mktplinkfw-lib.c This change is a semantic NOP (the code is unchanged). To ensure compatibility with gcc-5.x and newer without changing the code, -fgnu89-inline is added to the build flags for these two binaries. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 4f1f8d70f5..b7addbbb93 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -39,8 +39,8 @@ define Host/Compile
$(call cc,encode_crc)
$(call cc,nand_ecc)
$(call cc,mkplanexfw sha1)
- $(call cc,mktplinkfw md5, -Wall)
- $(call cc,mktplinkfw2 md5)
+ $(call cc,mktplinkfw mktplinkfw-lib md5, -Wall -fgnu89-inline)
+ $(call cc,mktplinkfw2 mktplinkfw-lib md5, -fgnu89-inline)
$(call cc,tplink-safeloader md5, -Wall)
$(call cc,pc1crypt)
$(call cc,osbridge-crc)