aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-08-22 17:30:44 +0200
committerJohn Crispin <john@phrozen.org>2018-08-28 11:26:53 +0200
commit8e9a59a6b924469c0061d4bd945ae0c6dbfdecfe (patch)
tree7914371eee00fbd443f0293f454e6d34e7d03274 /tools/firmware-utils/Makefile
parent8132e0624726f0df512f79052299a5790259cda0 (diff)
downloadupstream-8e9a59a6b924469c0061d4bd945ae0c6dbfdecfe.tar.gz
upstream-8e9a59a6b924469c0061d4bd945ae0c6dbfdecfe.tar.bz2
upstream-8e9a59a6b924469c0061d4bd945ae0c6dbfdecfe.zip
build: add mkrasimage
The current make-ras.sh image generation script for the ZyXEL NBG6617 has portability issues with bash. Because of this, factory images are currently not built correctly by the OpenWRT buildbots. This commit replaces the make-ras.sh by C-written mkrasimage. The new mkrasimage is also compatible with other ZyXEL devices using the ras image-format. This is not tested with the NBG6616 but it correctly builds the header for ZyXEL factory image. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 436a43794c..00917c3417 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -70,6 +70,7 @@ define Host/Compile
$(call cc,fix-u-media-header cyg_crc32,-Wall)
$(call cc,hcsmakeimage bcmalgo)
$(call cc,mkporayfw, -Wall)
+ $(call cc,mkrasimage, --std=gnu99)
$(call cc,mkhilinkfw, -lcrypto)
$(call cc,mkdcs932, -Wall)
$(call cc,mkheader_gemtek,-lz)