aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2019-01-12 20:18:52 +0100
committerMathias Kresin <dev@kresin.me>2019-01-15 19:11:54 +0100
commit26a016731d1fc1e2bd6b5f8d3af0fdbd631363ff (patch)
treeeb705752de643f8761b500a97bb1e725240ff65b /tools/firmware-utils/Makefile
parent18c9faa03211e29252413671610a93c00dcc7ad1 (diff)
downloadupstream-26a016731d1fc1e2bd6b5f8d3af0fdbd631363ff.tar.gz
upstream-26a016731d1fc1e2bd6b5f8d3af0fdbd631363ff.tar.bz2
upstream-26a016731d1fc1e2bd6b5f8d3af0fdbd631363ff.zip
firmware-utils: mksercommfw: overhaul image creation
Move the zip compression into a build recipe. Pad the image using the existing build recipes as well to remove duplicate functionality Change the code to append header and footer in two steps. Allow to use a fixed filename as the netgear update image does. Use a fixed timestamp within the zip archive to make the images reproducible. Due to the changes we are now compatible to the gnu89 c standard used by default on the buildbots and we don't need to force a more recent standard anymore. Beside all changes, the footer still looks wrong in compare to the netgear update image. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 68782f3802..864a3df15d 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -84,7 +84,7 @@ define Host/Compile
$(call cc,mkdhpimg buffalo-lib, -Wall)
$(call cc,mkdlinkfw mkdlinkfw-lib, -lz -Wall --std=c99)
$(call cc,dns313-header, -Wall)
- $(call cc,mksercommfw, -Wall --std=gnu99)
+ $(call cc,mksercommfw, -Wall)
endef
define Host/Install