aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2022-12-06 12:33:58 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-12-06 23:10:40 +0100
commitf72be4524d2c74a34eaea67edb45fbe745b48bba (patch)
treedd3478fc9b1be0e446c9627196588e4f13186386 /tools/cmake/patches
parent48025b8ac9c62ead241ea1daf1092993fb94aeac (diff)
downloadupstream-f72be4524d2c74a34eaea67edb45fbe745b48bba.tar.gz
upstream-f72be4524d2c74a34eaea67edb45fbe745b48bba.tar.bz2
upstream-f72be4524d2c74a34eaea67edb45fbe745b48bba.zip
tools/cmake: update to 3.25.1
Update cmake to version 3.25.1 * refresh patches Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
-rw-r--r--tools/cmake/patches/150-zstd-libarchive.patch2
3 files changed, 3 insertions, 3 deletions
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 6ef37c22cb..1744fe5b04 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -594,6 +594,14 @@ if(CURL_USE_OPENSSL)
+@@ -611,6 +611,14 @@ if(CURL_USE_OPENSSL)
endif()
set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 2b3ba361bd..70d122c9d9 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1441,7 +1441,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1449,7 +1449,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if test "x${cmake_parallel_make}" != "x"; then
diff --git a/tools/cmake/patches/150-zstd-libarchive.patch b/tools/cmake/patches/150-zstd-libarchive.patch
index 603ac03775..34f7240fe4 100644
--- a/tools/cmake/patches/150-zstd-libarchive.patch
+++ b/tools/cmake/patches/150-zstd-libarchive.patch
@@ -1,6 +1,6 @@
--- a/Utilities/cmlibarchive/CMakeLists.txt
+++ b/Utilities/cmlibarchive/CMakeLists.txt
-@@ -630,8 +630,13 @@ IF(ENABLE_ZSTD)
+@@ -632,8 +632,13 @@ IF(ENABLE_ZSTD)
SET(ZSTD_FIND_QUIETLY TRUE)
ENDIF (ZSTD_INCLUDE_DIR)