aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches/130-curl-fix-libressl-linking.patch
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2018-04-04 10:02:32 +0200
committerHans Dedecker <dedeckeh@gmail.com>2018-04-11 21:02:29 +0200
commita8c315192b750453e1b821ab735bdabca43a4d0e (patch)
tree652c014e0bdc95c00f12a3803267a4f9802c36d1 /tools/cmake/patches/130-curl-fix-libressl-linking.patch
parentf6e6eadc99c6274207f8f2ebc739063549959a1f (diff)
downloadupstream-a8c315192b750453e1b821ab735bdabca43a4d0e.tar.gz
upstream-a8c315192b750453e1b821ab735bdabca43a4d0e.tar.bz2
upstream-a8c315192b750453e1b821ab735bdabca43a4d0e.zip
tools/cmake: Update to 3.11.0
Update cmake to 3.11.0 Remove 110-alpine_musl-compat.patch as it's integrated upstream Rename and refresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'tools/cmake/patches/130-curl-fix-libressl-linking.patch')
-rw-r--r--tools/cmake/patches/130-curl-fix-libressl-linking.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/tools/cmake/patches/130-curl-fix-libressl-linking.patch b/tools/cmake/patches/130-curl-fix-libressl-linking.patch
deleted file mode 100644
index ad5b89750e..0000000000
--- a/tools/cmake/patches/130-curl-fix-libressl-linking.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From: Jo-Philipp Wich <jo@mein.io>
-Date: Wed, 11 Jan 2017 03:36:04 +0100
-Subject: [PATCH] cmcurl: link librt
-
-When cmake is linked against LibreSSL, there might be an indirect
-dependency on librt on certain systems if LibreSSL's libcrypto uses
-clock_gettime() from librt:
-
- [ 28%] Linking C executable LIBCURL
- .../lib/libcrypto.a(getentropy_linux.o): In function `getentropy_fallback':
- getentropy_linux.c:(.text+0x16d): undefined reference to `clock_gettime'
- getentropy_linux.c:(.text+0x412): undefined reference to `clock_gettime'
- collect2: error: ld returned 1 exit status
- make[5]: *** [Utilities/cmcurl/LIBCURL] Error 1
-
-Modify the cmcurl CMakeLists.txt to check for clock_gettime() in librt
-and unconditionally link the rt library when the symbol is found.
-
-Signed-off-by: Jo-Philipp Wich <jo@mein.io>
----
---- a/Utilities/cmcurl/CMakeLists.txt
-+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -461,6 +461,10 @@ if(CMAKE_USE_OPENSSL)
- set(USE_OPENSSL ON)
- set(HAVE_LIBCRYPTO ON)
- set(HAVE_LIBSSL ON)
-+ check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
-+ if(HAVE_LIBRT)
-+ list(APPEND OPENSSL_LIBRARIES rt)
-+ endif()
- list(APPEND CURL_LIBS ${OPENSSL_LIBRARIES})
- include_directories(${OPENSSL_INCLUDE_DIR})
- set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})