aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches/120-curl-fix-libressl-linking.patch
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-12-29 17:27:20 +0100
committerHans Dedecker <dedeckeh@gmail.com>2018-12-29 18:12:28 +0100
commit77429a820f8efff25c8e3c3e3579f636eff58fbc (patch)
tree9c5149c1a9a8f1706d64f2d5271e39ae2d56745f /tools/cmake/patches/120-curl-fix-libressl-linking.patch
parent335c69fbb21a21c9286f02d59fb40dc0a3e38c07 (diff)
downloadupstream-77429a820f8efff25c8e3c3e3579f636eff58fbc.tar.gz
upstream-77429a820f8efff25c8e3c3e3579f636eff58fbc.tar.bz2
upstream-77429a820f8efff25c8e3c3e3579f636eff58fbc.zip
tools/cmake: update to 3.13.2
Update to the latest stable version and refresh patches; see https://cmake.org/cmake/help/v3.13/release/3.13.html for the latest changes in 3.13.x Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'tools/cmake/patches/120-curl-fix-libressl-linking.patch')
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 20c5052cce..e217979ee4 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -452,6 +452,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -454,6 +454,14 @@ if(CMAKE_USE_OPENSSL)
set(USE_OPENSSL ON)
set(HAVE_LIBCRYPTO ON)
set(HAVE_LIBSSL ON)
@@ -34,4 +34,4 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
+ endif()
list(APPEND CURL_LIBS ${OPENSSL_LIBRARIES})
include_directories(${OPENSSL_INCLUDE_DIR})
- set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
+