aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cloog/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-22 16:23:15 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-24 09:40:46 +0100
commit3f55e5aeb5ef269db8e64eea1b113cb6daf20327 (patch)
tree90a175947042a299f160e9f6fba13891e59e724d /tools/cloog/Makefile
parent8bf69ee78cfefc0ee87d4a6820a907713e3bc1c3 (diff)
downloadupstream-3f55e5aeb5ef269db8e64eea1b113cb6daf20327.tar.gz
upstream-3f55e5aeb5ef269db8e64eea1b113cb6daf20327.tar.bz2
upstream-3f55e5aeb5ef269db8e64eea1b113cb6daf20327.zip
toolchain: remove ppl/cloog, disable graphite for gcc 4.8
graphite is disabled by default and it's not worth carrying ppl and cloog for supporting this feature on the old gcc 4.8, which is only used for ARC Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/cloog/Makefile')
-rw-r--r--tools/cloog/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/tools/cloog/Makefile b/tools/cloog/Makefile
deleted file mode 100644
index f392e0546e..0000000000
--- a/tools/cloog/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2009-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=cloog
-PKG_VERSION:=0.18.1
-
-PKG_SOURCE_URL:=http://www.bastoul.net/cloog/pages/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=02500a4edd14875f94fe84cbeda4290425cb0c1c2474c6f75d75a303d64b4196
-
-HOST_FIXUP:=autoreconf
-
-HOST_BUILD_PARALLEL:=1
-HOST_CONFIGURE_PARALLEL:=1
-
-include $(INCLUDE_DIR)/host-build.mk
-
-unexport CFLAGS
-
-HOST_CONFIGURE_VARS += \
- LIBS=-lstdc++
-
-HOST_CONFIGURE_ARGS += \
- --enable-static \
- --disable-shared \
- --with-ppl=$(BUILD_DIR_HOST)
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR)/$(3); \
- $(HOST_CONFIGURE_CMD) \
- $(HOST_CONFIGURE_VARS) \
- $(HOST_CONFIGURE_ARGS); \
- )
-endef
-
-$(eval $(call HostBuild))