aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bzip2/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-04-18 15:22:48 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-04-18 15:22:48 +0200
commitb691362d1dbe2c07e83c3e703f093dfd8e14145c (patch)
treea7bfb9eb1eae441cb790b40799bedc04f23bb2bd /tools/bzip2/Makefile
parentf7f47b1369917273b5a21a9fbacfaea80c60c16d (diff)
downloadupstream-b691362d1dbe2c07e83c3e703f093dfd8e14145c.tar.gz
upstream-b691362d1dbe2c07e83c3e703f093dfd8e14145c.tar.bz2
upstream-b691362d1dbe2c07e83c3e703f093dfd8e14145c.zip
Revert "tools/bzip2: add `bzip2` binaries"
This reverts commit 394d7134ec42f14ddb91769c737098753fa68266. The commit has unintentded change that cause compilation error with SDK or LZO compression. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/bzip2/Makefile')
-rw-r--r--tools/bzip2/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/tools/bzip2/Makefile b/tools/bzip2/Makefile
deleted file mode 100644
index 0c5a92849a..0000000000
--- a/tools/bzip2/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2022 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bzip2
-PKG_VERSION:=1.0.8
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://sourceware.org/pub/bzip2
-PKG_HASH:=ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269
-
-PKG_LICENSE:=bzip2-1.0.8
-PKG_LICENSE_FILES:=LICENSE
-PKG_CPE_ID:=cpe:/a:bzip:bzip2
-
-HOST_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/host-build.mk
-
-HOSTCC := $(HOSTCC_NOCACHE)
-HOST_CFLAGS += $(HOST_FPIC)
-
-HOST_MAKE_FLAGS+= \
- CFLAGS="$(HOST_CFLAGS)" \
- LDFLAGS="$(HOST_LDFLAGS)" \
- ENABLE_BIN_SHARED=1 \
- ENABLE_BIN_STATIC=0 \
- ENABLE_LIB_SHARED=1 \
- ENABLE_LIB_STATIC=1 \
- ENABLE_DEV=1 \
- ENABLE_DOCS=1 \
- ENABLE_TESTS=0 \
- PREFIX="$(HOST_BUILD_PREFIX)"
-
-define Host/Configure
-endef
-
-define Host/Uninstall
- $(call Host/Compile/Default,uninstall)
- $(call Host/Compile/Default,clean)
-endef
-
-define Host/Clean
-endef
-
-$(eval $(call HostBuild))