aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-28 01:23:56 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 00:33:22 +0200
commita63805b25f99e609d575ee920baae269fb58794c (patch)
tree3d7090484571e2b300efdd658033378c250a485e /tools/bison
parentf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (diff)
downloadupstream-a63805b25f99e609d575ee920baae269fb58794c.tar.gz
upstream-a63805b25f99e609d575ee920baae269fb58794c.tar.bz2
upstream-a63805b25f99e609d575ee920baae269fb58794c.zip
tools: add Host/Uninstall where possible
This cleans staging_dir when calling tool/x/clean. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/bison')
-rw-r--r--tools/bison/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 5f96463ae0..30555541e6 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -19,14 +19,14 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --enable-threads=posix --disable-nls
-define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
-endef
-
define Host/Install
$(call Host/Install/Default)
$(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
endef
+define Host/Uninstall
+ rm -f $(STAGING_DIR_HOST)/bin/yacc
+ -$(call Host/Compile/Default,uninstall)
+endef
+
$(eval $(call HostBuild))