aboutsummaryrefslogtreecommitdiffstats
path: root/tools/automake/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-11-10 17:44:13 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-09 21:33:18 +0100
commit3606fcce0ba2ede47c3fe47b0b62033df2d231dd (patch)
tree93d3e8c4ec2fe1f9250f9265a074b95bc64a7030 /tools/automake/Makefile
parent9988832c464054847c22188e65b22cf0f86f25e6 (diff)
downloadupstream-3606fcce0ba2ede47c3fe47b0b62033df2d231dd.tar.gz
upstream-3606fcce0ba2ede47c3fe47b0b62033df2d231dd.tar.bz2
upstream-3606fcce0ba2ede47c3fe47b0b62033df2d231dd.zip
automake: use STAGING_DIR_HOST in relocatable patch
Instead of using STAGING_DIR and then go up one dir with '../' use directly STAGING_DIR_HOST env variable. This should produce cleaner symbolic links. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/automake/Makefile')
-rw-r--r--tools/automake/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index a1121f1378..85ccc0ded4 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -25,7 +25,7 @@ HOST_CONFIGURE_VARS += \
am_cv_prog_PERL_ithreads=no
define Host/Configure
- (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap)
+ (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR_HOST="" ./bootstrap)
$(call Host/Configure/Default)
endef